MS Store version crashing to desktop randomly

:arrow_forward: GAME INFORMATION

  • BUILD #: ######
  • PLATFORM: / Microsoft Store
  • OS: Windows 10

:arrow_forward: ISSUE EXPERIENCED

:question: DESCRIBE THE ISSUE IN DETAIL (below). Limit to ONE issue per thread.

Crashing to desktop randomly, here is log:

:arrow_forward: FREQUENCY OF ISSUE

:question: How often does the issue occur? CHOSE ONE; DELETE THE REST.

  • Less than 25% of the time / matches I play (RARELY)
  • 25% of the time / matches I play (SOMETIMES)
  • 50% of the time / matches I play (FREQUENTLY)
  • 100% of the time / matches I play (ALWAYS)

:arrow_forward: REPRODUCTION STEPS

:question: List the DETAILED STEPS we can take to reproduce the issue… Be descriptive!

Here’s the steps to reproduce the issue:

  1. Updated GPU drivers
  2. Tried to fix in apps in Windows 10

:arrow_forward: EXPECTED RESULT

:question: What was supposed to happen if the bug you encountered were not present?

:arrow_forward: ACTUAL RESULT

:question: Crashing to desktop randomly, can go 5 mins into game no issues, then random crash, or 30 mins into game then random crash.

:arrow_forward: GAME FILES

:question: NONE

:arrow_forward: IMAGE & ATTACHMENTS

:question: LOG:

===============================================================
File ‘Age3Log.txt’ opened at Thu Oct 15 20:58:53 2020

===============================================================

PreGame 48520: Account Event - New State: AttemptingLogIn, Old State: Invalid, Last Error ID: None
PreGame 53753: License Query Task Queue Initialized: 0x00000000
PreGame 53764: License Query Store Context Initialized: 0x00000000
PreGame 53766: License Query Result: 0x00000000, Active: True, Trial Status: { False, 4294967295, not owned }
PreGame 53766: License Query Begin: 0x00000000
PreGame 53766: License Check Status: 1
PreGame 53767: Game locale: English
PreGame 64038: SetupMovie: 1920 x 1080 C:\Program Files\WindowsApps\Microsoft.MSGPBoston_100.12.1529.0_x64__8wekyb3d8bbwe\Game\Movies\AOE_Microsoft.bk2
PreGame 66751: SetupMovie: 1920 x 1080 C:\Program Files\WindowsApps\Microsoft.MSGPBoston_100.12.1529.0_x64__8wekyb3d8bbwe\Game\Movies\Tantalus.bk2
PreGame 69454: SetupMovie: 1920 x 1080 C:\Program Files\WindowsApps\Microsoft.MSGPBoston_100.12.1529.0_x64__8wekyb3d8bbwe\Game\Movies\ForgottenEmpires.bk2
PreGame 71960: Game startup complete (71.96 sec)!
PreGame 71960: ------------------------------------------------------------
PreGame 75646: SetupMovie: 1920 x 1080 C:\Program Files\WindowsApps\Microsoft.MSGPBoston_100.12.1529.0_x64__8wekyb3d8bbwe\Game\Movies\IntroMovie.bk2
PreGame 104688: Account Event - New State: LoggedIn, Old State: AttemptingLogIn, Last Error ID: None
PreGame 241800: Got WWAS response sessionID=64922, steamLobbyID=0, xboxSessionID={“templateName”:“GameSession”,“name”:“f61aa1b7-4dfc-4c10-8ab5-0009aeeadf84”,“scid”:“00000000-0000-0000-0000-00006e53310c”}
PreGame 241800: Got WWAS response sessionID=64922, steamLobbyID=0, xboxSessionID={“templateName”:“GameSession”,“name”:“f61aa1b7-4dfc-4c10-8ab5-0009aeeadf84”,“scid”:“00000000-0000-0000-0000-00006e53310c”}
PreGame 243614: XboxPlatform::TrackSession() - added RL session 64922
PreGame 308123: WorldwidePartyService::DisconnectInternal() - attempting disconnect from session 64922
PreGame 308172: XboxPlatform::UntrackSession() - removed RL session 64922
PreGame 455154: WorldwidePartyService::DisconnectInternal() - attempting disconnect from session 64019
PreGame 455173: XboxPlatform::UntrackSession() - removed RL session 64019
PreGame 455833: WorldwidePartyService::DisconnectInternal() - attempting disconnect from session 64019
PreGame 591059: XboxPlatform::TrackSession() - added RL session 65726
PreGame 645396: WorldwidePartyService::DisconnectInternal() - attempting disconnect from session 65726
PreGame 645465: XboxPlatform::UntrackSession() - removed RL session 65726
PreGame 815678: WorldwidePartyService::DisconnectInternal() - attempting disconnect from session 66090
PreGame 815697: XboxPlatform::UntrackSession() - removed RL session 66090
PreGame 859768: XboxPlatform::TrackSession() - added RL session 66286

1 Like

Same here, did everything on my side.
Still crashes. May need to wait for a fix.

I updated to windows 10 ver 2004 and seems to be ok now.

Solved by installing .Net Framework 3.5

Nice one, mine was already installed, but updated Windows and not had a crash since.

Spoke to soon, just had a crash :frowning:

Both myself and a friend have been experiencing crashing issues on the MS Store version also; It just completely exists the game to the desktop. I haven’t been able to have a full multiplayer match yet. The campaign is working fine.

Both PC’s are updated to Windows 2004, and we also tried installing Net Framework 3.5 as mentioned in this thread.

I wonder if the Hotfix that is already applied to Steam and scheduled for this coming week will fix it? This is unplayable at the moment.

I have been experiencing the same crash issues. Painted desert map ~10 minutes into the game. Just random crash to the desktop and no error message.

1 Like

Same Here I bought xbox GamePass And I have no problem with game no lag nothing only this very annoyng Crash random

Same… Net.Framework 3.5 is not the solution.
Faced two crashes today but i also disabled page filing on both ssd’s today before playing.
Turned it back on, going to try tomorrow again.
Only happens with AOE 3 DE, AOE 2 DE works perfectly fine.

Enabling page file solves the issue.
16 GB of ram and System controlled page file on the system disk.