Multiplayer frame drop in late game, become unplayable

:arrow_forward: GAME INFORMATION

GAME BUILD : latest to the 29-04-2024 - GAME PLATFORM: Steam - OPERATING SYSTEM: Windows 11

:arrow_forward: ISSUE EXPERIENCED

Games frame rate drop to 1 fps in late game, in every type of lobby I create (or I got invited to). It seems like a bug only for player with an AMD setup. My friends with NVIDIA/Intel hardware have no problem at all. Searching on other forums, other player that have this issue have AMD hardware (GPU mostly), sometimes the same as mine (AMD Radeon RX 6600M).

:arrow_forward: FREQUENCY OF ISSUE

Happens on 100% of the matches.

:arrow_forward: REPRODUCTION STEPS

Just start a game with AMD hardware, even vs AI, and in late game (40+ minutes in) at the moment of battling fps will drop below 10.

:arrow_forward: EXPECTED RESULT

The game was supposed to work fine, I have a more than adapt setup to play this game and the issue just started recently. Last year I had no problem at all with the same PC.

I’m not sure if the developers can help you with your issue, although this may be specific to the 6600M. If so I’m sure they will look into it.

A common problem with all GPU’s (AMD or NVIDIA) is heat dispension after a few working years. This is even more the case with laptops as you are using the AMD 6600M GPU chip (for mobile use).

Most times fans get clogged with dust in just a few years and will trigger automatic adjustment of the GPU performance to way less than before, if it wouldn’t do that the chance on severe damage (burning) of the mainboard and/or other components could happen which even could cause fire through shortage. As in laptops the CPU uses the same cooling construction, the same throttling happens there too.

The powerdraw of the AMD 6600M can reach 100 watts, although designed at 7nm this still translates in quite some heat exposure.

To check if it’s related to heat you can check by holding your hand close to the fan outlets and by feeling around the body of your laptop numerous times towards the 40 minute barrier. Be careful as it could be hotter than expected. You could also use any kind of free monitoring tool that supports your AMD chipset and GPU.

So check your temps and make sure your fans are not clogged with dust. After a few years of usage it’s recommended to do this while also replacing the old dried up cooling paste. And if you are living in a very dusty environment once a year. Raising your laptop from the surface by using a laptop stand could also help for better hear dispension and less dusty airflow.

The game was running fine a year ago on the same PC, so it must be some patch/update they released recently that screwed something up.

Temperature are fine, below 100°C (if that’s fine for AMD I guess) and I played far more demanding game on this PC without any issue. So heat is not the problem here, nor throttling.

On another forum someone said that AoE doesn’t stress enough the GPU so the clock doesn’t reach the minimum frequency to wake it up. Basically it’s like using the GPU for nothing and it goes to sleep. They said that running another app that quite draw attention on the GPU can wake it up so it does 2 jobs at once good. I tried running another game while playing AoE today and FPS never dropped below 80. Maybe this is the problem? I’ll do further tests with this method but honestly it’s not a normal thing to do.

Hope devs will caught hear of this and fix it, I wanted to get some expansion too but I doubt to play this game in this state.

Amazing but annoying work around ofc.

Well, this for sure is interesting for the developers. In the plethora these days of single and dual GPU combinations something could be wrong here with compiling the last build.

Yeah probably, I’ll keep updated this thread with more of my tests. Hope they see this and fix the bug.

1 Like

The problem is the gpu itself specially the 6000 series, the game can’t stress it enough so the gpu goes to sleep mode constantly providing a terrible stutter, nvidia or intel doesn’t have the same issue as their GPU clock and their shaders/cudas are not linked at the same clock speed, i believe the 7000 series don’t have this issue cause they separated the shaders clock, but your only solution is to open another 3D app while playing to stress the gpu so it stays awake.

1 Like

As a current 6950xt user and a former TITAN RTX user, I can confirm this. With my 6950xt, my GPU is constantly sitting at a power usage of well below 100 Watts while playing and the game frequently drops to a single-digit FPS during mass battles in 4v4, so I assume it’s not even trying to put much work into it.

Then I tried to do a workaround by running the GPU-Z render test in the background so the game could be [under load], the game ran a lot better (but still bad in my opinion with a card like this) with a GPU power usage of around 120 W, and the 1% low was also increased to double-digits.

It has to be fixed soon.


I just did a deeper dive into this problem and there are some things you could try or check out.

Although an old post I do find this one particularly interesting for you all.
laptop - How to make GPU use high performance settings instead of power saving? [Dual Graphics] - Super User

And then we also have Windows power management interfering with performance on mobile platforms. As my laptop is always powered by a main outlet I put the Windows power scheme on high power mode.

After automatically installed game updates (by Steam or MSS) it might be necessary to delete and re-add the game again in the catalyst software because the digital signature changed and so the specific required power settings configured for the previous executable are not applied.

On my laptop with Windows 11 and Intel IGP with Nvidia RTX 3000 performance isn’t managed anymore by the Nvdia driver but by Windows itself, so also check the list of games and their performance setting in Windows settings → system → monitor → graphics.

As this still is a problem specific to certain AMD cards they might need some help from AMD to solve this issue or maybe some kind of a mod could help keeping this card alive.

edit: ddg search url was blocked, so removed that link, search was ‘amd catalyst turn of energy saving’.

Catalyst isn’t a valid software anymore I think, that post in from 8 years ago too. Now there are 2 (shitty) software for AMD and on vboth of them I have set to use the high performance GPU for AoE. Even in the Windows settings I set it to use the dedicated GPU.

From what I read in the advice there is to not do that (putting it on dedicated). Also managed by Windows means in my case that those settings in Nvidia control panel for specific games do not apply anymore.

As most regular users will never touch or even find those settings I can understand that choice.

Fun fact is that in Windows settings → system → monitor → graphics there are a lot of games listed, some on high performance and others on balanced, except for AOE II DE. Although installed it’s not listed at all there. Lately I played the other new versions.

Did some more tests. I tried running FurMark (using 640x360 resolution) while playing. That brings the GPU to 300+ watts but the game still stutters during mid/late games. While it is indeed GPU-intense, turning it off or leaving it on makes no difference to the game, the game still stutters as usual.

I really don’t know if this is an issue from AMD or the game itself. Would be a shame if replacing the graphic card is the only solution.

Done more tests with Barotrauma open in background (not a really demanding game btw) and in late game it never drop frames below 15/20. An improvements, shitty one but still it is one. So seems like we understood, at least I think, the problem. From my pov I think it’s a AoE bug not an AMD one: game should take enough resources from a GPU to not let it sleep even if it doesn’t need that much. And in late games it should use all of the resources it needs to avoid stuttering/fps drop.

Done another game few minutes ago, literally unplayable: 1 fps in late game for few minutes, couldn’t help my friend and we lost that game. Are dev gonna fix this? I literally uninstalled the game, since it’s impossible to play, it was a waste of storage space.

I am also having the same problem. I tried running Vermintide 2 in the background and the game is unplayable. Units freeze, ignore orders and messages are delayed. The game is so unplayable that Vermintide 2 was working fine. I could even queue up a mission for the game while AoE2 struggles with 1 fps.

The fact is that we have to pray a dev see this, or other posts with the same problem, to finally have a patch. In the state as it is now it’s just a waste of storage on my PC, since shit drops at 1 fps when the AI starts to attack seriously.
Honestly it’s been nearly a month and I’ve seen no answear from official aoe channel, so I’ll check the game in a year, maybe they fix this

No AMD here, but NVIDIA. The game is just unplayable for me… The frame rate drops to 0 for minutes sometime… Literally zero. I cant do anything.

The devs need to fix this quickly, or they should go back to the latest working patch.

I hope they do honestly, still no dev here

Devs usually dont really react that much…

Well how the players should notify a bug? I mean this is a big thing that’s gone under the radar apparently

I hope they still read.