Multiplayer Server Issues March 21, 2020

Game Version:

  • Version: 101.101.35584.0
  • Platform: (Microsoft Store)
  • Operating System: (Windows 10)

Issue:

When playing any multiplayer game with bots (any kind of AI), game laggs until it gets delay e.g. half a minute and more. For example with my friend i finished the game and he was playing for another two minutes within time 1 h (1.5x). This problem persists when playing alone multiplayer game versus bots. Weird thing is playing on even westus servers is no problem, almost no laggs. That means problems are the bots. Its sad, because for start, we wanted to train on bots. :frowning:

Reproduction Steps:

Here’s how to reproduce the problem:

Just create multiplayer lobby with bots and play for 5 minutes, it gets unplayable very soon.

1 Like

i have exactly same problem. When playing with bots the game stops responding to commands, but other player sees it. You just “play” in different timeline, well actually you don’t play because you just keep clicking but villagers dont respond.

1 Like

Same thing here.

This is a consistent issue that’s been happening to a lot of players, a lot of times.
I have some friends that just feel regret about buying AOE2 DE because of this problem.

I hope it gets fixed soon.

Some topics regarding this issue:


1 Like

Game Version:

  • Age of Empires II: Definitive Edition
  • Microsoft Store

Issue:

Neither my friend nor I are able to join each other’s private LAN lobbies. We simply get a message that says “Unable to Join Lobby”. We have adjusted all firewall port settings and ensured that our PCs can communicate with each other.

Reproduction Steps:

  1. Create private lobby.
  2. Set server to LAN.
  3. Send invite to clan member.
  4. Error

THE SERVERS ARE DOWN

We are quarantined because of SARS-Cov2 and can’t even play AoE2-DE because the servers are down.

Microsoft, you are not helping us here… This is UNACCEPTABLE!

FIX THE SERVERS NOW!

10 Likes

I have the same problem. When I try to create a Lobby it says “Could not create game. Error: Connection failed.” Playing ranked games doesn’t work as well. :frowning:

all servers are red (high ping ) same like 24 hours ago !

What if… the server have a virus… oeh think about that.

But here also problems “Unable to create party. Error: Connection Failed”.
Same as yesterday.

Bump. Servers have been down for last few hours. Please fix ASAP <<<<<<<<<<

Bump again. Would rather play than watch TV… Help!

1 Like

Not even so much as an acknowledgement from Microsoft… please get on this

1 Like

They haven’t even posted any notifications on their social media regarding server issues, or responded to people reporting the issue.

There is a problem with servers every evening for last week. I dont know why nobody from Microsoft cannot fix it. Please fix it finally!

1 Like

@Realinho @DuplexMussel716 Everyone is welcome to post on these forums. If you are new, please quickly read the forum code of conduct. That said, the multiplayer servers are currently under maintenance to resolve the current issues. Please be patient and respectful towards other forums users, including staff members.

Same here. Second day in a row, in a worst possible time. :frowning: Any explanation from devs why is this happening?

same here :confused:

Servers are back online as of 5pm PT Thank you for your patience!

2 Likes

THANK YOU, MY FRIEND!!! The game should have an update to allow future warnings about server maintenance.

1 Like