( :( need help) self-created map will not show in the mod manager in game

After creating a map with content editor by following the instructions on the official website, the self-created local mod was not shown in the mod manager in game, even though the sga file appeared in document/user/AoE4/mods/extension/local folder (Did exactly the same thing as the instruction showed, and everything went smoothly except the mod was not shown in the mod manager). As @aryaford pointed out in previous thread, I also tried to move the location of document folder to the same drive where game locates, but it did not work (The system drive does not has enough capacity for AoE4, so I moved the document folder from the system drive to other drive)

1 Like

Let’s go through a couple of steps to make sure we find the issue here.
Did you press on the Build Mod option?
The Burn menu next to this can be confusing for people and it doesnt do the same thing.

What kind of content are your creating?
Crafted Map ? Generated Map?

If it is a Crafted Map, can you check if the Scenario Type is set to Multiplayer in the Info section of your Scenario file properties.

In the game, if you go to Mods tab, you should see your Mod in the Mod Publisher menu.

Let me know if that helps.

I appear to be running into the same issue. Double checking all of the steps you suggested did not fix the problem. Do you happen to have any other ideas?

Thanks in advance for any help.

Hi, seabass, thank you for the advice, but although I ensured I followed your steps, the issue is still there. However, I found this problem just mythically disappeared after I once tried to create a generated map and directly built the mod. After this, both the crafted and generated map I made can show up in the mod manager in game.
Although did not figure out the real problem, but it works now.
(for other players who may encounter this issue, maybe try to make a generated map first, and without altering anything, just directly built the mod to see whether it will appear in the mod manager in game or not?)

1 Like

I actually dont know what would cause an issue like this.
I just have the game installed on my E drive, my mods I work on are all in my Documents folder and my sga files are saved in Documents/My Games/AoeIV…

Oh might be linked to the name of your mod.
some characters might not work or if the name of the mod is too long.

try a simpler mod name
also make sure there is a description to your mod