Need Help with Unit Weapon

Hello Guys,
I createt a modpack and wanted to change the damage of Royal knights, the problem was that they use the common knight weapon. so if i change that every knight will have those damge, but i only want to effect Royal Knights. I cloned the weapon but toggle “Clone Override Parent Settings” of. Now i changed the damage and went to the hardpoint menu were the weapon can be select. I choose them. i went ingame and testet it. i have many questions, because in age2 the knight now havent the weapon and charge insteat only the trochdamage, but in age 4 it worked. Can u guys help me?

Did you update the weapon for all versions of the Royal Knight? This guide shows how to modify multiple versions at once:

(ignore the bit about “mass propagation” - cloning core units seems to be broken right now - don’t do this)

I checked it and correct those were the false weapon was selected, now the charge is shown ingame but not the meele sword

Knights have three weapon hardpoints. In order:

  1. Melee (Sword)
  2. Torch
  3. Charge

Are you sure you updated all of them? Are the animator_attachments correct for all three Ages (II, III, IV)?

I’m trying to set up a copy myself, but I’m at work so taking a bit of time haha.

All Meele Sword. do i have to coppy trorch and charge as well?

Definitely make sure they’re set as hardpoints. I don’t think you need to clone them though, unless their damage also needs updating.

Now it is like this:

Is it working?

It looks like you’ve modified the third weapon slot as well (the charge).

Nope i didnt modify it its dark black cause of diffrent charnges (2,3,4). No Meekle Sword either

So I got this working at my end. I’ll describe what I did.

Cloned unit_knight_2_fre (and 3, and 4):


Cloned weapon_knight_2 (and 3, and 4) and rename them (added “fre” to the end):


Cloned weapon_knight_2_charge by mistake. Don’t do this! Royal Knights have a unique charge weapon :slight_smile:

Deleted the charge weapons I cloned, and then cloned weapon_knight_2_charge_fre (and 3, and 4):


Updated the weapon non_entity_weapon_wrapper_pbg references (for 3 and 4 as well):


I forgot to upload a pic of the Age 2 version, but here you can see Ages 3 and 4 working (I upped their sword and lance damage by 1 each) :slight_smile:

The weapon also animates correctly (switches to sword for an attack move, goes back to lance for idle / movement).

ok thanks ill try )im playing right now)

still no sword damage

ill try it tomorrow again

If you cloned any core units, delete everything and start again. Not sure what else could be going wrong.

i tryed twince first time it doesnt worked but second try were i make a video it worked, thanks for help, i have a nother question: were can i decide how many burst shots i want to shot?

Haven’t looked into shot mechanics, sorry. That might be tied to an animation as well.

ok but thanks for helping, i like that aoe4 moding have a great community

1 Like