New achievements not being granted

:arrow_forward: GAME INFORMATION

  • GAME BUILD #: 93001
  • OPERATING SYSTEM: Windows 11

:arrow_forward: ISSUE EXPERIENCED

Builder of Civilizations achievement was not granted after I’ve completed the Ascent of Egypt campaign, on hard difficulty even.

:arrow_forward: FREQUENCY OF ISSUE

:point_down: How often does the issue occur? CHOSE ONE; DELETE THE REST!

  • 100% of the time / matches I play (ALWAYS)

:arrow_forward: REPRODUCTION STEPS

:point_down: List CLEAR and DETAILED STEPS we can take to reproduce the issue ourselves… Be descriptive!

Here’s the steps to reproduce the issue:

  1. Play the Ascent of Egypt Campaign and complete it.
  2. See that the achievement is not granted.

:arrow_forward: EXPECTED RESULT

:point_down: What was SUPPOSED to happen if the bug you encountered were not present?

The achievement Builder of Civilizations to be granted once the Ascent of Egypt campaign is done.

:arrow_forward: IMAGE

:point_down: ALWAYS attach a PICTURE (.jpg, .png, .gif) or VIDEO (.mp4, YouTube link) that highlights the problem.




You’re right, I finished both today and the achievements didn’t fire.


It’s a bug, the team is aware of the issue and working on a solution.

1 Like

Bumping this! Have the same issue (also please fix the Tours achievement bug, I’ve been denied my 100% ever since it was added!)

Do you mean the Tour d’Italie achievement?

Its probably Tours co op

New achievements are working on the PUP. You have to replay one scenario. I played the last egyptians’ and got both achievements, so Im not 100% sure it works with any map of one of them

Just so! I’ve tried just about everything to get the Co-Op achievement to work–with an AI, friend, multiple difficulties, etc. @Felizon89

Steam achievements work now, but Xbox ones still won’t unlock.

If anyone stubles upon this with same problem as me. It seems that something went wrong when old companion app was turned off. I fixed it by clearing cache in MS Edge.