New GPU suggestion

Thanks for doing that. So we can clearly see you do NOT have a temperature issue and your GPU is NOT unstable at constant high loads. Both are good things. I do see that the core frequency of your RX 590 is a bit high. Did you overclock it or do you have a 3rd party overclocked card? Core should be running at 1469 Mhz stock. Yours is at 1560 which may cause instability. Try bringing the frequency down a few notches.

In any case, Unigine should’ve crashed so we can still assume your problem is isolated to AoE4. Something in your system (or a combination of things) is not playing well with the game. Until you find what’s the deal, if I were you I would not buy a new GPU (that’s a very expensive way of testing).

It could be that one of your RAM modules is corrupting data, or the combination of hardware+drivers you have installed is causing AoE to crash, or even specific BIOS settings. There’s still a lot to uncover but we at least know that your GPU is perfectly fine. The only scenario in which your GPU could still be the issue is if its built-in memory was corrupt, but that’s a very rare thing to happen.

  • Do you have XMP enabled for your RAM? If you do, disable it temporarily and play the game.
  • You may want to run a memory health test (they tend to take very long to complete, so leave it running overnight).
  • Bring down all graphics settings in AoE to the lowest possible options. Play the game. Didn’t crash? Begin bringing up each setting, one-by-one until it crashes again. What caused it? Increasing texture fidelity? Increasing screen resolution? Geometry?
  • As I said before, you can try downclocking and undervolting your GPU slightly.
  • If the game still crashes after all that, I would then blame the game and not your system, especially if no other games have issues. Open a support ticket and submit all your Dxdiag details.

Imagine installing a brand new 6600XT and getting the exact same problem. That’d be beyond frustrating, so make sure you eliminate all potential culprits first.

I have not overclocked my GPU, and do not have the XMP enabled, and never have had it.

I ran the Memory Health Test the other day, no issues were detected.

I will try playing the game in lower settings and post the results. In the meantime, i have played Dying Light 2. The temperature started at 58, and as i played for about an hour, it reached it’s peak of 72°, which in my opinion is very good, considering the model of this GPU is XFX Fatboy, which is known to have a peak of 84°. I had no crashes, black screens, or any other issues for that matter. It seems that my case cooling is decent after all.

Could an issue be some other component, such as PSU, or maybe a CPU?

PSU not really, cpu tho, maybe, depends what you have

If you plan to get a 6600xt, im using one and have a 2k monitor. Id go 6700xt or higher if you want to be close to max setting.

1080p you should get max setting. Thats my setup at the moment

You should enable it. Some memory modules don’t like running “underclocked” and will bug out.


I’ve got a question in my mind and I’m wondering if someone can solve it.


16 RAM
M.2 hard drive
resolution 2560x1440
msi optix mag series 165hz display(currently playing at 100hz to avoid sudden fps drops)
G-sync active

I’ve been playing at 100hz for a while now and it seems that I had practically solved the stuttering problem although now with the new patch I have small fps drops in lategame that makes the game stutter sometimes.



The case is that to me with the camera stopped I have 244.2w of gpu power. Is that normal? my power supply works fine?

With 144hz I get a terrible stuttering that prevents me from playing smoothly.

Thank you very much! :slight_smile:

Some AMD users get hard locked playing the game, it’s been a year since the developers have been told about AOEIV hard lock, the game locks and you can’t alt tab or alt f4 etc so you have to hard reset, all you can do is hear the game in background.

People can’t hear you either if you are on voip with them, but you can hear them.

It’s still not fixed as I just reinstalled and had one.

It’s for this reason I’d suggest Nvidia, I love my AMD card but it’ll be the last one for a reason, some games ironically more often RTS games cause this issue, and it’s not just for me, there’s threads about it on reddit.

You don’t need 144hz/144FPS Screen for this game, really, 60 FPS is plenty, more than that is nothing to see or gain from AoE4.
Cap your FPS for AoE 4 in Nvidia Ctrl Panel in Program settings TAB - add Aoe 4, set Max frame rate -60, Monitor Technology should be set on Fixed Refresh not G-Sink. The game ignores his own settings of FPS.
After that you’ll see prolly half of power usage on you GPU.
Playing AoE 4 with more than 60 FPS, you are throwing money out on the window in electricity bills.
The power usage I see in your pictures is normal for your card. 3070 Ti can pull out of the wall over 300 W easy.
Your PSU works fine? I don’t know. Make and model will help. But more will help, if you test it.
Run Furmark in a window for 10 min along Furmark window run HWinfo opened to the power tab and watch +12 V +5V and 3.3V if are ossifications of + or - more than 5 % of those voltages than you need to change your PSU, the more constancy of those voltages, the better. You don’t need oscillations in the power delivery.

Did you try changing in game settings to window to see if you can alt tab?

Interestingly enough, a fix for me was disabling freesync,