New update causing GPU overheating

:arrow_forward: GAME INFORMATION

:point_down: These details are CRITICAL; DO NOT skip them or your issue may not be reviewed.

  • GAME BUILD #: 93001 (latest update 6th September)
  • OPERATING SYSTEM: Windows 11

:arrow_forward: ISSUE EXPERIENCED


Ever since the latest update my GPU has been overheating and just generally working really hard whenever I start up the game. Playing a normal game in single player quickly gets GPU temperatures up to 80°C. Prior to the update, temperatures would be around 50°C while playing, despite all my settings staying exactly the same. Have tried changing the font to Smooth Serif but this doesn’t help much (some have suggested this as a fix)

For reference, my GPU is a Nvidia GTX 1650

:arrow_forward: FREQUENCY OF ISSUE

:point_down: How often does the issue occur? CHOSE ONE; DELETE THE REST!

100% of the time

:arrow_forward: REPRODUCTION STEPS

:point_down: List CLEAR and DETAILED STEPS we can take to reproduce the issue ourselves… Be descriptive!

Here’s the steps to reproduce the issue:

  1. Start the AoE2 and go into any game
  2. Monitor GPU temperature (although the fan gets audibly much louder anyway)

:arrow_forward: EXPECTED RESULT

:point_down: What was SUPPOSED to happen if the bug you encountered were not present?

My GPU not overheating almost instantly


That happened to me also.
My GPU almost never overheats, but it did today while playing a single player scenario.

Glad I’m not the only one! I actually only recently re-installed AoE2, so good that I did it before the update or else I’d not have much to compare it to.

But yep, we’re talking about a 30 degree difference literally overnight playing the same game. It’s ridiculous.


This also leads to negative Benchmark test scores on players who had it positive.

1 Like

Any idea when/if there will be a fix for this?

1 Like

Those of us that were already on the low end, performance wise, have found overnight that the game is just impossible to play.


limit your FPS in game setting so it doesn’t go to like 500 fps and overheat your GPU

No change by putting everything at a minimum. If it were that simple there wouldn’t be a Bug report here :slight_smile:


no idea man, you gotta ask the dev. when people reported the issue they still decide to push the update.

doesn’t matter how low you set the graphic it still happens

not for me. I had mine set at no limit and it was hitting like 85C then I tested at like 60fps and 120fps theres a clear difference. of course different hardware may behave differently but the idea behind them should be the same.

Checking the second oddly solves performance problems for many players (from the FR community).

going into options>UI>and choosing smooth serif made the performance better again

It doesn’t work for everyone, and there are reports on Reddit saying that after activating it it got better, but after a while it stopped getting better.

And even when it improves, it’s not 100%, it just eases.

great game. filled with riddles letting the player test for them instead of testing the game prior pushing update.

better yet, ignore the PUP bug report from players and continue to push the update.

Known issue, the team is investigating the issue. Thanks for your report :slight_smile: