New uploaded mods not working again

as titles suggest, only old mods work , newly uploaded ones dont work

works for some but not everyone

1 Like

i have the same problem

Hey @AzzeddineXT and @Vaultecdude! There was (is?) a bug where some would see that, despite the mod downloading correctly. Did you happen to try to start the game?

i am the mod creator so the mod works fine for me, tested it on singleplayer just fine
the problem is 50% of the people joining the lobby have this error, and the start game button is greyed out when they have this error so i cant start the game

what you mean by (is?)
all i saw is in the screenshots above

all this people joined my lobby and downloaded my mod from scratch, worked for some but not all
but if i switched to official mod : “double villagers”
it worked fine for all of them

i had a friend having the mod issue today in the lobby
he fixed it my going manually to mods and resubscribing

possible fix is to make the people who join the custom lobby download the mod from the actual servers, not from the host

Thanks @AzzeddineXT! The team is looking into functionality here, though the info on a workaround is super helpful.

1 Like

one more thing about uploading the mods my self

i keep getting disconnected and reconnected over and over everytime someone join the lobby (i have bad upload speed)
arent they supposed to be server sided not client?

Hey @AzzeddineXT! Is this something you see often/every time, or just the one time?

occasionally , depends how many people join the lobby at one time
as for mod i made new one from scratch and it seems to work now