No games showing in lobby browser

Game Version:

101.101.34793.0 4597979

  • Build pc?
  • Platform Steam


I did the update everything went normally, but when I went on multiplayer and lobby browser no games load up but the servers come up on the right. I tried refreshing but nothing happens. when I actually click onto 'searching for games I can see a lobby host on the right side of the screen.

i can play ranked play but i enjoy unranked more as its easier and more relaxed. please let me know how to resolve

Reproduction Steps:

  1. I did the most recent update and this has happened.


Same… I’ve got same issue

allows me to play ranked but cant see lobbies on lobby browser since 2 days ago


Same for me, haven’t played this week so AFAIK it might have happened in the last 4-5 days.
34793, Steam, Windows 10 if that matters.

Both Lobby Browser and Spectate Games show the same thing, however if I click on “Seaching for games” in the list, I see a game in the bottom right. The button to spectate the game lights up, and I can join it.

Joining a friends lobby just gives me a constant loading screen (that I can cancel, so it isn’t frozen), however he can see me enter the lobby, and sees me leave as soon as I cancel my loading screen. I can also hear any taunts made in the chat room while I’ve got my loading screen up, so it’s just like the game works perfectly in the background while the load screen just blocks me from seeing anything.

Tried waiting while loading both the lobby browser and while joining my friends game for ~5 minutes each, no result.

EDIT: Things I’ve tried without success:
Restarting the game
Restarting Steam
Disabling all mods
Restarting my computer
Restarting my router
Use Steams “Verify integrity of game files” function
Reinstall game from scratch


I started having this problem yesterday !
It is horrible.
Please fix it !


everytime since 3 days ago…


Logging out of Xbox Live worked for me, can see lobbies again. Might work for others too, as a temporary fix until it’s patched.


wow it literally worked straight away once i tried it! thanks :smiley: