No Matchmaking happening for 2v2, 3v3 and 4v4

Hi, I don’t know if I am the only one facing this issue right now but this is quite concerning and irritating at the same time, I’ve tried many a times, specially for the last week, no matchmaking is happening how long I try! 1v1 is sometimes fine, but it feels like there’s just one or two players there as well, and both of us are being matched times and times again!

Anyone having any idea what the heck is going 9n here?

Check that your game is patched and up to date on the latest version .

Thanks… I did that now… But even after updating, matchmaking is far away…

Are you on the PUP? People aren’t really matchmaking on the PUP as it’s intended for testing custom game features.

1 Like

In my limited knowledge, I don’t know much about PUP, and I didn’t see any option for PUP on Xbox App for PC, I’m playing it on PC via Xbox live app, I’ve bought AOE4, it’s a standard edition, and it opens up in a simple way, I click on the icon and the game starts, then I choose Multi player etc…

Doesn’t sound like you are on PUP then.

How long are you typically waiting? it can take up to 3-10 minutes to find a game, depending on your time of day and timezone.

I think there’s a bug going on with Xbox users still being on the LAST patch, the game doesnt update for them automatically for some reason, which explains why he sees no other users.
You have to do it manually somehow, there are instructions on google. You should report it to the devs if thats the case

I just realized I needed to update my AOE IV game on Microsoft Store as it doesn’t auto update through the xbox app.

You need to sign into the Microsoft Store app and then go to your library and the update should show up there.

My game matching was getting bad also. 5min+ in some cases.

I’ve updated the game now… Still matchmaking sucks…

Did it get any better after updating? Cause I did that and I still have the same problem

for 1v1 it did. Games are coming a lot faster

True, that’s part of the problem

Looks like it was because of the Xbox PC App or Microsoft Store, the issue is that the update (the last patch, March 10th) isn’t out there, I’ve tried several times to get it done by app but it didn’t work out, turns out that I should purchase the app on Steam rather than being stuck with the heck of Xbox and it’s allies’ nonsenses!
So, I bought it on Steam, and not to my surprise, it worked really well, now I’m getting matched in no time.

I play on gamepss and I have no problem at all to find games

Which version of the game do you have? Cause the latest is 11963

The last upgrade done by microsoft store was done in 10th March. And it is the 11963