Objectives glitch on Sargon of Akkad:Subartu campaign mission

:arrow_forward: GAME INFORMATION

:point_down: These details are CRITICAL; DO NOT skip them or your issue may not be reviewed.

  • GAME BUILD #: Version 101.102.42346.0 (#107882) 13720908
  • GAME PLATFORM: Steam
  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED

:point_down: DESCRIBE THE ISSUE IN DETAIL (below). LIMIT TO ONE BUG PER THREAD.

Main objective “Gain control over [#] megalithic structures (Ruins)” glitches and shows that I need control over “0” structures. I have gained control of all 8 structures, but the game never registers the objective as complete so the mission is unwinnable.

:arrow_forward: FREQUENCY OF ISSUE

:point_down: How often does the issue occur? CHOSE ONE; DELETE THE REST!

  • 100% of the time (ALWAYS)

:arrow_forward: REPRODUCTION STEPS

:point_down: List CLEAR and DETAILED STEPS we can take to reproduce the issue ourselves… Be descriptive!

Here’s the steps to reproduce the issue:

There are no steps. Happens every time I start the mission.

:arrow_forward: EXPECTED RESULT

:point_down: What was SUPPOSED to happen if the bug you encountered were not present?

Main Objective should be 7, I think, structures need to be controlled to complete the mission.

:arrow_forward: IMAGE

:point_down: ALWAYS attach a PICTURE (.jpg, .png, .gif) or VIDEO (.mp4, YouTube link) that highlights the problem.

:arrow_forward: GAME FILES (SAVE / RECORDING)

:point_down: Attach a SAVE GAME (.aoe2spgame) or GAME RECORDING (.aoe2record) of the match where you encountered the issue. Link it below if using an external file service.

https://1drv.ms/u/s!AiDGgSWmn5GByTR2akaJAnYzW5hI?e=lpczEK
(Linking save file since it’s telling me new users can’t upload files)

1 Like

Just confirming that I am also seeing this bug on PC (Xbox app), can’t complete the scenario, and also can’t upload a save game thanks to the new user restriction. The current objectives shows “8/0 Ruins captured.” when in control of all objective locations. There is also a script error when the scenario first begins.
SargonBug

1 Like

I have the same issue on the PC/Xbox version.
Capture
Capture 3
Capture 2

Hello everyone,
Thanks for reporting the issue, it is tracked by the team.

Has there been any information on a fix for this? I am still having the issue even after the Hotfix that came out on 4/4/24.
Capture 3
Capture

1 Like

Same issue here. Very frustrating.

As of 4/8 I am still seeing this issue as well. Can’t complete the mission

I am still having the same problem as I reported earlier. Has there been any progress by the devs on finding what the issue is with this campaign mission?

If anyone wants this achievement while the bug is still present there is a workaround. Set EVERYONE to enemy and then force them to surrender by destroying all their buildings - the mission should complete.

Just tried this and it doesn’t finish.

As Azrael said, Yellow and Grey wont surrender even after being fully wiped from the map. Even tried removing every red wall. The map also has some patches that will remain ‘unexplored’ on the mini-map even though you have already uncovered them on the game map. The level in general is just not working.

Also, Green never moves. If you pay them or if you don’t, they stay in their corner unmoving.

I was told by support that they are aware and to keep an eye on the forums. That was two weeks ago. The most recent update fixed some of the bugs regarding achievements but did nothing to help this campaign sadly. I’ve kept up with the forums and heard no other mention aside from more complaints of the same issue with no comment or acknowledgement.

Change diplomacy to enemy on every remaining civs and destroy them all…you will win

You won’t. That is what these last few comments have been about. Literally doesn’t happen. I’ve tried it twice. Neither ally will resign after you put them as enemy.

Setting everyone as an enemy and destroying every building (even walls and farms, though that may not have been necessary) did work for me and I was able to finish the campaign.