Offline issue, either "sign in" or "exit"

I have read a bunch of stuff both here and other places about this topic (and done the “how to play offline” thing from Nothing helps.

When I start the game offline, I get this message:

So - I can either sign in, which of course is not a possibility offline, or exit the game. When I try to hit “sign in” anyway, it says it cannot sign in and that multiplayer and cloud storage is unavailable. And then the “sign in” or “exit” message shows up again.


First of all it seems that you post a screenshot of the old AOE DE client. That version is not officially supported anymore.

It’s known to have bugs regarding offline play. The only way to play this version offline is to sign in first with internet connection, then disconnect from internet and leave the game running in your taskbar (you can minimize it) and use the sleep function.

Thanks, I thought I had bought it after 19th of Aug, but seems I actually bought it that day. I have the wrong client.

Anyway, trying to update it, but it does not show in the “Get updates” site on Store. I’ll try a “hard re-install”.

You don’t get the free update alert after starting the old client?

Actually you don’t have to remove the old client. The one that is listed in the store now is the new client. I performed the update following the notification from the old client.

And it still reminds me now and then although the new client is installed already.

No, I didn’t get any notice…

I’ve re-installed now. Says build 27374 now, as it does in your screenshot as well. Seems to have fixed the issue for me. But, only tested once, so we’ll see! At it says it should be build 28218…

Well, at least it has partly solved your problem.

Do you run the latest Windows 1903 version or older?

It’s a requirement for the latest AOE DE version.

I run the latest version…

Look in the Microsoft store for age of empires: definitive edition, you should have the option to install it, which is what you want to do. There are two versions of it in the Microsoft store, one of them has a gray picture within the store and the other has color, the one with the color is the one you want.


To install that version they of course demand the admin mail and password for system administration / update (which I do not have, as I’m using a computer from work).They have definitely gone out of their way to make this difficult for me I see.

Thanks to both of you for you help anyway. Guess I need to get friendly with the IT department…

1 Like