Original Game stopped working after installing BETA

Hello!
I have installed the beta, downloaded some mods and even made a map on the editor and played a game on a generated map.
After exiting and going back to the normal version of the game (changed from future_live to “none”) - it wont work anymore.
It shows a black screen and the AOE4 mouse cursor, and crashes soon after.
Re-installed the game and the crash still occurs.

Please help! Im completely unable to play the game :C

1 Like

Hey there @Bidderlyn ,

Did you receive a Steam Key for the Content Creator and access it from your Steam Library? Or did you access it via other means?

Please try deleting the Age of Empires IV folder (under Documents/My Games) and re-launching to see if that resolves the issue.

1 Like

Hi, I had the same exact issue, I tried deleting the AOE 4 folder and Test from Documents/My Games, verified integrity of game files via steam, made sure to opt out from future beta to none. Re-opened the game and still experiencing the same crash as above after uninstall and reinstall twice now. I downloaded some of the map mods available once I was in the future live game, and decided to opt out of it cause no one else was online that I could find in lobbies for hours.

With this it sends me back to intro setting customization, tutorial, and then upon finishing or exiting the tutorial, crashed and now we’re back at square 1.

This is exactly what I did with the exact same result.

@LeJuanJames1738 Explained it better than I could, im stuck at the same spot as them

Hey @Bidderlyn & @LeJuanJames1738 ,

We’re going to need some additional information to look further into this. Please use the steps HERE to send us a copy of your DxDiag, Warning Logs, & Session Data files.

It would also be helpful to know if you:
A - Accessed the Content Creator via your Steam Library (required use of Steam Key)
or
B - You accessed the Content Creator via an alternative route

Thanks!

Hi! @Licidy
I used the EssenceEditor.exe in the path \Steam\steamapps\common\Age of Empires IV
Dont know if that falls under “A” or under “B”, guess b?
I simply double clicked it, followed a guide someone posted here on how to open the editor.

Edit: Alright I have submited a ticket, further explaining the issue in a more concise way

Thanks @Bidderlyn !
Yes, that is path B. Thank you for confirming.

  1. Steam Library right click on Age of Empires IV and select properties
  2. Select “Betas” in the left sidebar
  3. Change option for, “Select the betas you would like to opt into” and set to “none”
  4. Steam will say the game is downloading - wait for this to complete
  5. Launch game.

IF THE GAME SHUTS DOWN IMMEDIATELY ONCE OPENING AND YOU OPENED THE MAP EDITOR BEFORE. FOLLOW BELOW

  1. Navigate to C:\Users\[ your user folder]\Documents\My Games\Age of Empires IV
  2. Open file warnings.log with Notepad or any text editor
  3. Scroll to the bottom of the file or search for the word Failed in a text editor or Notepad. Here will identify what went wrong.
  4. In my case (yours might be different) it was trying to load my test map when I was experimenting with the map editor. You can see in the path below it’s trying to call Test_Map_2.sga.
(I) [17:47:11.085] [000016176]: ARC -- D:\SteamLibrary\steamapps\common\Age of Empires IV\mods\extension\Campaign\Campaign.sga 24916748 B [ID:2b68be0ca3f34580bb867f188bb77459] [Ver:36bc8041fb9162edad2cbcd3155015f1] [Sig:3029092349686401518]
(I) [17:47:11.519] [000016176]: ARC -- C:\Users\[redacted for privacy]\Documents\My Games\Age of Empires IV\mods\extension\local\Test Map 2\Test_Map_2.sga 5330008 B [ID:205dfb8dc8e74e02a488f085febe44d3] [Ver:5b6615384b08d3677fa044be3f29e2b2] [Sig:0]
Failed during load of []
Type checksum mismatch for executable type checksum 4215048333 against baked object checksum 3372643453 for TypeID 2166646047061842755 [Mod]
  1. For my issue, I navigated to C:\Users\[redacted for privacy]\Documents\My Games\Age of Empires IV\mods\extension\local. This path will be different for you if you received an error similar to mine
  2. Deleted my Test Map 2 folder from the path in step 10. This folder will be named whatever you named your test map if you opened Map Editor at any point and compiled.
  3. Launch game and it will work

Issue is that for some reason the map editor when you run a build of a map, it sets a path in the current version of the game and not the test version. Because the current version of the game doesn’t support mods yet, it will fail, causing the game to quit.

1 Like

Hey there @Bidderlyn , @LeJuanJames1738 , and anyone else with this issue,

We believe this issue is related to launching the Content Creator from the EssenceEditor.EXE file directly. Launching it in this manner is not supported at this time and will result in mod data being saved to your retail profile instead of your temporary beta profile.

To resolve this issue, please see the steps on this FAQ page:

2 Likes

That worked!
Thank you very much!


I followed the steps and was able to relaunch the game up to the point where I finally get to the main menu and I see the mods map I downloaded while in future live try to be reintegrated. I’m going to relaunch future live, delete the maps data, and then go back to the original to see if that remedies it. Each time I permanently deleted the mods folder it kept reintegrating after each relaunch and crashing the game to the screenshot you see here. I checked the warning logs after that. > (I) [12:20:17.824] [000017096]: ARC – C:\Users\User\OneDrive\Documents\My Games\Age of Empires IV\mods\extension\subscriptions\51907\aoe_cb4f9d18-4643-4e7b-89fb-c705d6fca498.sga 1014420 B [ID:7e51dea8206b479dac90b514f2dadf46] [Ver:905dd185180210d736351bb2f59bdb66] [Sig:0]

(I) [12:20:17.824] [000017096]: Failed during load of []
Type checksum mismatch for executable type checksum 4215048333 against baked object checksum 3372643453 for TypeID 2166646047061842755 [Mod]
(I) [12:20:17.826] [000017096]: D3DLOG Begin
(I) [12:20:17.826] [000017096]: D3DLOG End

Hi there @LeJuanJames1738 ,

Could you please use the steps HERE to send us a copy of your DxDiag, Warning Logs, & Session Data files. This will help us better diagnose the issue.

I also see from your post that your My Games folder is located on your OneDrive. Can you confirm that you’re deleting the MODS folder from the OneDrive backup copy as well? It could be that your backup copy on OneDrive is syncing and overriding your local deletion of the MODS folder. Thanks!

Thank you! This resolved the issue for me :slight_smile: