Out of memory error

Need help

I’ve now lost all hope, like 3/4 games on AoE4 i Get the “out of memory” message and game force closes, I have the exact same laptop as my mate and his doesn’t do it. I’ve even factory reset the laptop and it’s still does it… I keep my eye on the RAM usage through task manager and it did it yesterday with 1.8/2GB remaining so it must be something the game is doing as I’ve seen a few people complain about the same error but no real solutions, I’ve seen posts about it happening with 8/16gb RAMs.

I’ve done the following

  • factory reset laptop
  • increased my virtual Memory
  • fresh install of the game
  • I’ve ran checks no errors etc showing
  • updated both Nividia and Intel graphic cards through their sites.
  • updated my pc
  • disabled all overlays
  • optimised graphics and made aoe priority
  • close all background apps

It never used to do it but now it’s happening all the time but only on Age of empires 4

1 Like

2GB RAM is not suffisant, you can try anything you want it will not be possible to play this game.
Actually this game contains many memory leak and even with 4GB it will run out of memory.
I am playing with 8 GB (the minimal configuration) and it even crashed due to bad memory access.
So yeah I dunno who develop this game or its engine, but it’s bad asf.

Many games require more than 4GB of RAM; to do so is not evidence of any memory leak. The game itself lists 8 as minimum on Steam, so anything less than that is going to cause problems.

I’m not sure the OP has 2GB of RAM (that’d be surprising in this day and age), I think maybe this happens with 1.8 to 2GB of RAM remaining (unused), but it does sound like some form of hardware issue (though if it only affects Age IV, it might not be hardware either).

Was this ever solved? I have 8GB RAM and got this message a second ago.

Do you still suffer from it when most other running programs are closed?

And / or do you still suffer from it if you lower specific settings (I’d imagine primarily anything related to textures, as they’re likely to eat up a lot of memory at runtime)?

Trying to work out if a) there’s something that can mitigate the issue while you’re playing, and b) work out if this is working as intended for machines with limited available memory, or if it’s something that’s happening if you have 8GB regardless of how much spare the machine has at any one time (which would be a bug they need to sort).

Yes I have everything else closed currently

I haven’t tried that yet, I will let you know on this.

However I doubt it as I have a gtx 1850 graphics card

And yeah great questions I’d love to know, I may just need to upgrade ram

Update: it does happen no matter what graphics setting I use

Says memory unable to write

Only happens while browsing custom games after a match, not even during the match.

1 Like

I’d recommend attaching your DxDiag for the devs, I’m obviously no Age IV developer but that does sound like a bug.

1 Like

Tbh it happened to me during games not every game but I did a number of things and it doesn’t happen or hasn’t happened lately but my main idea on why this happened was age of empires was telling my computer to use my built in graphics card over my better one which I finally managed to force it to use the GeForce try running task manager and see which GPU it’s running off if you have more than one

1 Like

Ty for the suggestion but I only have one graphics card

In the past I played only with the AI 4v4. The game lasted much over 2 hours and then it told me I’m out of memory’. I had 32 GB. It happens also within a replay that lasted over 2 hours. Now I have 64 GB but coudn’t tell if this problem is solved with it because I train now against ‘hard’ 2v2 and do not reach to 2 hours so … . But I’m very sure that my sytem is ok. And to report ‘out of memory’ sounds not like a bug. It comes out of the game for me. A crash is something else I think. But I’m definitely not sure. Just my 2 cents. :grin:

1 Like

This is a good note as it usually only happens to me after large hour plus 4v4 matches

1 Like

I would say it’s a bug with the game because there isn’t much online about it but from what I’ve found it’s happening to people with different RAMs ranging from 8-32GBs.

Try minimising RAM on boot up, disable a lot of start up programs and overlays I also adjusted my RAMs virtual memory.

1 Like

All of my computer is already optimized for these types of games

No startup programs, like a 25gb paging file

Probably just the crap engine relic has tbh

Feels like a memory leak from empire Earth 2

1 Like

It had me stressing as my brother has the EXACT same laptop and it never happens to him

I know there is at least one memory leak from checking masteries. Perhaps there are others I dont know of.

So mabye trying to straight shoot it from the title to your game as best you can
might help.

Best of luck to all of those with… unconventional computer set ups.
Id love to see you all smashing that AoE4 with us.

1 Like

It is most likely a memory leak as I’ve noticed mine only seems to happen if I doodle about before playing a 3v5 match but if I go straight on and into a game it rarely happens

1 Like

I have 16GB of RAM and this “out of memory error” is happening once every 3 or 4 games. It is very frustating to buy an expensive computer and still not being able to play an “average” graphic game. We have to spend a lot of monney on a “gamer” PC and it is not enough (if you are playing from a developing country like Brazil, you are likely to spend about 5 minimum wages to set up an average PC, including monitor, keyboard and mouse).

I have 64GB of ram and get the out of memory whenever I make a lot of Outpost like over 50, and the system at hte time says I’m only using 13GB of total ram out of 64,

  • Right-click the Start button to open its context menu.
  • Then click on System > Advanced system settings.
  • On the System Properties box, ensure that you are on the Advanced tab.
    Click the Settings button from under the Performance section.
  • On the Performance Options box, go to the Advanced tab. Make sure background services is checked.
    Click the Change button from under the Virtual memory section.
  • On the Virtual Memory box, uncheck the Automatically manage paging file size for all drives checkbox.
  • From the available list, click to select the drive on which Windows 10 is installed. (C: in most cases.)
    Make sure it says system managed size and then click ok.

It should be ok if not let us know. Worked mine out. Hope this helps.

The game STILL isn’t fixed! Every single time I try to save my game, it crashes. This shouldn’t be happening on a high end gaming computer. Literally no other game I own does this, and most are much more taxing CPU-wise than this game. What is going on?! When will you fix this?!?!?!? Game is unplayable at this point, which really sucks considering I’ve been playing AOE since the very first one. Probably gonna have to get a refund at this point. You guys still do not seem to care, especially with all the treads of people asking you to fix this MASSIVE game breaking issue.

1 Like