Out of sync error during multiplayer using crossover for Mac

:arrow_forward: GAME INFORMATION

:point_down: These details are CRITICAL; DO NOT skip them or your issue may not be reviewed.

  • GAME BUILD #: ######
    Latest as of March 13th 2021
  • GAME PLATFORM: Steam / Microsoft Store
    Steam
  • OPERATING SYSTEM: Windows 10 / Windows 8 / Windows 7 / Mac / Linux
    Mac using crossover

:arrow_forward: ISSUE EXPERIENCED

:point_down: DESCRIBE THE ISSUE IN DETAIL (below). LIMIT TO ONE BUG PER THREAD.
Whenever I try to play a Multiplayer game at the loading screen I see my town center and villagers, then I get an ‘out of sync’ message. The game works fine for single player.

:arrow_forward: FREQUENCY OF ISSUE

:point_down: How often does the issue occur? CHOSE ONE; DELETE THE REST!
100% of the time

  • Less than 25% of the time / matches I play (RARELY)
  • 25% of the time / matches I play (SOMETIMES)
  • 50% of the time / matches I play (FREQUENTLY)
  • 100% of the time / matches I play (ALWAYS)

:arrow_forward: REPRODUCTION STEPS

:point_down: List CLEAR and DETAILED STEPS we can take to reproduce the issue ourselves… Be descriptive!

Here’s the steps to reproduce the issue:

  1. Use a MacBook Air M1 to install crossover
  2. Install Steam from within crossover, creating a steam bottle
  3. Search for age of empires 3 de under install new software within crossover and install aoe3
  4. Launch steam from within crossover, then download and install aoe3 using steam.
  5. Ignore warning messages, play a single player game to verify it worked
  6. Create a 1v1 supremacy skirmish ranked game using all default setting
  7. Wait for a match
  8. Out of sync error occurs

:arrow_forward: EXPECTED RESULT

:point_down: What was SUPPOSED to happen if the bug you encountered were not present?
The game is supposed to start and supposed to be able to play a multiplayer game

:arrow_forward: IMAGE

:point_down: ALWAYS attach a PICTURE (.jpg, .png, .gif) or VIDEO (.mp4, YouTube link) that highlights the problem.

:arrow_forward: GAME FILES (SAVE / RECORDING)

:point_down: Attach a SAVE GAME (.aoe3Ysav) or GAME RECORDING (.aoe3Yrec) of the match where you encountered the issue. Link it below if using an external file service.

1 Like

How about you fill the form its ment to be. They literly tell you, if you dont fill this form they will ignore your post.
2. Are you sure your operating system is 64 bit ?
CrossOver can’t run 64-bit Windows applications. 64-bit Windows applications use different APIs than 32-bit Windows applications and it’s this translation that’s missing from CrossOver and preventing 64-bit programs from running. Whether the native Mac/Linux operating system is 32/64-bit doesn’t matter.

You are incorrect. AOE 2 DE runs fine, and AOE 3 DE also runs fine except it fails multiplayer with an out of sync error because it requires slightly different dll files to run. It would be nice if they made tweaks to allow apple M1 devices to run the game, I’m sure they want to sell more copies of the game and M1 owners I think would love to play.

Also, no idea what you are talking about not filling out the form correctly, I did fill it out correctly as far as I can tell.

I just told you what Crossover ITSELF states on its website.

  • " Latest as of march 31 " Is not a valid game build
    " Gameplatform " still showing both options.

:arrow_forward: FREQUENCY OF ISSUE

:point_down: How often does the issue occur? CHOSE ONE; DELETE THE REST! CHOOSE ONE DELETE THE REST

So crossover agrees that it doesn’t work. So what? We already know that. That is kind of the entire point of making this post, so the AOE3 devs make it compatible.

This is Microsoft. You think they care about Mac users ?
Mac is not for gaming :slight_smile:

They do care about Mac users, they even made bootcamp available to run on Macs. I think they care about money. If they can allow the game to run on M1 macs, they will have X number of additional sales.

Hey guys - same issue here. M1 has some weird flickering issues (in fog of war), but the main concern is the Out of Sync for me as well during multiplayer.

Btw. this happens on Crossover, Porting Kit and Parallels (essentially all the top solutions for M1 Windows virtualization). Hoping for a solution.

Hi all, is there an update on this bug?

One note: For whatever reason it now works under Parallels but not with Crossover. It did not work under Parallels before, either, so something must’ve changed.

Does AOE 2 DE multiplayer work on parallels? I’d love to play it on an M1 Imac.