Pathfinding issue. vils trying to walk through stone

:arrow_forward: GAME INFORMATION

:point_down: These details are CRITICAL; DO NOT skip them or your issue may not be reviewed.

  • GAME BUILD #: Update 56005
  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED


rec.aoe2record (3.4 MB)
In the attached skirmish game against AI i sent some vils to build a castle on the opposite side of a a stone pile. The first time i just ordered them to move to the future castle site (because i was still halfway through researching Castle age) the second time i actually placed a castle foundation. Both times the vils tried walking through the stone pile, in vain. So i had to place an additional waypoint throught the gates.
Please refer to the the attached replay. 26:50 - 27:10

:arrow_forward: FREQUENCY OF ISSUE

:point_down: How often does the issue occur? CHOSE ONE; DELETE THE REST!

i don`t recall this happening in previous builds

:arrow_forward: REPRODUCTION STEPS

:point_down: List CLEAR and DETAILED STEPS we can take to reproduce the issue ourselves… Be descriptive!

Here’s the steps to reproduce the issue:

  1. Make it so that the closest path to a task would be through a stone pile
  2. Order the task
  3. Watch‘em trying to walk through stone

:arrow_forward: EXPECTED RESULT

:point_down: What was SUPPOSED to happen if the bug you encountered were not present?
In previous builds the vils were smart enough to make a detour through gates or other openings.

:arrow_forward: IMAGE

:point_down: ALWAYS attach a PICTURE (.jpg, .png, .gif) or VIDEO (.mp4, YouTube link) that highlights the problem.

I attached a .rec file. Please watch the 26:50 - 27:10 timeframe (view lock can help)

:arrow_forward: GAME FILES (SAVE / RECORDING)

:point_down: Attach a SAVE GAME (.aoe2spgame) or GAME RECORDING (.aoe2record) of the match where you encountered the issue. Link it below if using an external file service.

attached rec.aoe2record (3.4 MB)

Hey @L0omaster , thanks a lot for this report!
We are now tracking the issue.
Hope youll have a nice day.

Thank you.
By the way, i also had the same issue with relic blocking the nearest path. A vil stubbornly tried walking through relic

1 Like