Performance issue related to max population limit


OS, Hardware: Win 11 22h2, CPU: i78700k, GPU: RTX 3070
Power plan: Max performances
AOE4 version anniversary
Settings: High, very high, vsync 60 ON

I didn’t see if this bug had already been reported. Sorry if already reported.

Steps to reproduce the bug:

  1. Produce 200 units with a civilisation allowing 200 max population.
  2. Train 1 more unit
  3. At the end of training this unit, the game begins to stutters/lag badly when moving/spanning camera whereas previously it is perfectly smooth.

Additional note:

If you remove this additional unit, the stuttering disappears.


Problem sounds solved after last nvidia drivers update: 526.86

idk if this still indicates an area where performances could be improved on AOE4 developers side, but it is solved

1 Like

Thank you for reporting @Player809376002! Updating your drivers was an excellent step towards resolution. That said, the best thing to do for any performance related issues in general (assuming updated drivers), is to contact support with your DxDiag and warnings.log file.

Glad it’s working better for you!