Player Icons Not Unlocking

Game Version:

  • Build: 101.101.36202.0 4819260
  • Platform: Steam
  • Operating System: Windows 10
  • Gamertag: WarSunTzu

Issue:

My profile statistics page isn’t updating my number of wins and player icons aren’t unlocking. The number of games played keeps increasing, but the number of wins does not. I did unlock the spring update icons successfully, but it stopped unlocking my icons for number of wins, including number of wins with a particular civilization.

Reproduction Steps:

Here’s how to reproduce the problem:

Not sure. The only two changes I can think of are that I downloaded the spring update and I signed into Xbox live when I had originally downloaded the game through Steam.

ATTACHMENTS:

6 Likes

bump, have the same issue here

same issue, pls check it out.

1 Like

I currently have this issue as well, my overall wins and losses still update but my civilization wins are not, plus I’m not unlocking player icons, I was at 95 wins with Teutons and have gotten another 20 or so since and its still at 95.

Hello, this is luckily already tracked issue, thanks for the report nonetheless.
Have a nice day.

1 Like

Im not getting the 10 wins civ icon here. I have 14 sarracens game won and im not getting the icon.

same, i play burgundians but my wins are stuck at 88 even tho i had 4 wins reccently

You can 1v1 an ai in skirmish with standard settings to get it, I got my last 5 with Teutons doing this and unlocked the 100 wins picture, id had easily over 120 wins with them now so I felt it was ok to do.

This problem has been around for so long. The fact that such a little simple thing like this is not fixed by now is an absolute joke. It’s probably been 6 months or longer now.

1 Like

Yeah I have the same issue. I’m hunting the 100 wins with every civ. Already have britons, Franks and Lithuanians. But I’m easily at 150+ wins with goths and it isn’t unlocking. Super annoying.

Hello everyone!

Do you still have this issue? Can you tell us which civs are not working for you?

Thanks!