Plotstopper in Temples of the Aztecs: Cannot build Trading Post at the Aztec village

:arrow_forward: GAME INFORMATION

:point_down: These details are CRITICAL; DO NOT skip them or your issue may not be reviewed.

  • GAME BUILD #: 100.12.23511.0
  • GAME PLATFORM: Steam
  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED

:point_down: DESCRIBE THE ISSUE IN DETAIL (below). LIMIT TO ONE BUG PER THREAD.
The Trading Post building cannot be built at the Aztec village. The cursor stays red and the foundations cannot be placed.

:arrow_forward: FREQUENCY OF ISSUE

:point_down: How often does the issue occur? CHOSE ONE; DELETE THE REST!

  • 100% of the time / matches I play (ALWAYS)

:arrow_forward: REPRODUCTION STEPS

:point_down: List CLEAR and DETAILED STEPS we can take to reproduce the issue ourselves… Be descriptive!

Here’s the steps to reproduce the issue:

  1. Start the Mission “Temples of the Aztecs”
  2. Go to the village with the hero Morgan
  3. Try to build the Trading Post, as the first mission objective commands

:arrow_forward: IMAGE

:point_down: ALWAYS attach a PICTURE (.jpg, .png, .gif) or VIDEO (.mp4, YouTube link) that highlights the problem.

1 Like

This is really frustrating, is there any way to fix this or work around this? Can I unlock the next scenario without losing Steam achievements?

I have encountered this problem, and I reinstalled the game to solve it

It isn’t fixed by verifying game files in Steam, which should fix issues like these. But I will try a complete reinstallation.

Reinstallation didn’t fix this.

Fixed by Hotfix 24632.

Hi - I’m on version v. 100.12.30181.0 and this issue still persists. I’m a GamePass ultimate member and it’s up to date as far a Microsoft store. I’ve re-installed and it didn’t help.

Any ideas?

It is still not fixed.
I am now stuck on this mission.
Can confirm that reinstalling the game does not fix it.

Game version: 100.13.12327.0

Update: Changing the UI layout to classic fixed it for me.

I have the same Game version: 100.13.12327.0 and I have changed the UI to classic but the issue is still there. Any update please.