Problems with map transfer and problem to ready up in multiplayer lobbies

Game Version: 101.101.35209.0

Build 4667120
Plattform Steam

Issue: It seems like the map has to be transfered every time ? not sure about that, but so many times people cannot ready up aswell. We had it a lot of times, so just check it out and you will see.

Reproduction Steps:

  1. Open multiplayer lobby with some players and a no standard map
  2. Try to ready up for all players…many times it wont work

Signed up to report the same bug. The issue OP is describing has been happening to me since 2020-02-17, before that it worked fine.


Some additons to the OP:

  • People can’t ready up without map transfer (this seems new also)
  • Map transfer commences when host readies up
  • People can now ready up but some get kicked when they do (unsure what the criteria is here)
  • I tried the following: Restart the game, resubscribe to custom map (land nomad) but the problem persists

Exactly, its a new problem

So, to clarify some things:

UGC that you’re not subscribed to will be always downloaded when joining UGC a lobby, because the UGC you download at a lobby you don’t get to keep, it gets saved on a temporary folder.

And that’s a thing since the game launched, it’s just how it works for download from the lobby host.

That being said, the ready button will not be available to click when I join a lobby with UGC 100% of times. To be able to get ready I need to rejoin the lobby, sometimes twice or thrice even. This issue only showed up for me on build 35209. I play on Steam as well.

Yes, I just mentioned it as a necessary intermediate step. Before people could ready up before map transfer but had to ready up again after the download was completed. At least I think that’s how it was before.

1 Like

Oh, right, I got it now.

The way that worked before was that as a guest you could ready up at any moment. If the host weren’t ready already, you would download the map as soon as they got ready, and then have to ready again after the download finishes.

If you had the lobby UGC beforehand, then there were no need to download it and ready again.

1 Like

I’ve seen UGC prompt players to subscribe to the UGC when they join the lobby when it is an .rms being hosted from the mods directory. I think this prompt is avoided when users copy the .rms file to their steams game directory, because I don’t always get a prompt to subscribe but instead it will sometimes just auto-download once I ready. I’m only guessing it depends on where the host has their .rms file.

But this bug is a huge pain. Regardless of how UGC is hosted, I now have to ask the host to Ready Up so that I can see if I am bugged. if he waits until the lobby is full before he ready’s up, then I find that I am bugged meaning I cannot ready up, then I try to rejoin but the lobby is now full! If they had ready’d up from the start I could have rejoined before it was full!

To be clear, when the host checks “I’m Ready”, the clients sometimes remain with a greyed out “I’m Ready” Button. I have seen this whether I have the UGC pre-installed or not.

As host I have seen my lobby fill to 8, then someone tries to rejoin because of bug, but noone comes back, so I I check lobby browser and it says i have 8/8 players when my lobby really only has 7/8. This remains until i close and open the last slot, and uncheck ready then recheck ready.

And please, for the love of whatever you consider holy, Make the default value for team be set to “?” instead of “-”

“Set your Team!”
“P5 Set Team!”
“No not your player number”
“No not your civ!”
“Set your team you knob!”
“kick the noob”
“kick him”

I doubt most people are trying to play free for all.
Make this end.


This bug still persists after the latest update 36202.

I agree.

Alltough you have to download the map still if you already have it from a mod etc…

This problem needs to be heavily pushed. Starting lobbys with custom maps is such a huge problem…

This is the most frustrating part of the AOE2:DE experience right now. It’s on the Steam and Windows builds. I don’t know when it first appeared but it’s a plague in the current 36202 and the previous 35584, and probably even earlier versions.

Just to re-iterate. The symptoms are:
Players will receive the message: “* The Host is configuring lobby settings which may require a file transfer *”
and the I’m ready button will be disabled.

If the UGC content tranfers then all will be good. But often it does not.

Having the UGC beforehand and/or subscribing to the mod doesn’t fix it. I’ve even manually copied the .rms over into my game directory. It doesn’t matter. The host still needs to send and my client still needs to download all the UGC into the temp folder. This happens every time.

I found out you can bring back the I’m ready button if you change all the game settings to not have any UGC. Then the host can apply all the UGC stuff. However, the files still won’t send. You can launch the game and then it will crash (because the players are missing the files).

It’s not limited to just random map script files .rms’s. I have the same issues with transferring custom AI’s.

Also, why is the file transfer so freakin slow!?

You can make this problem a little less annoying by removing the marker in “Options > Game > deactivate warnings”

Then the game will always ask you for map transfer but you dont have to rejoin.

All that option does is remove the yes/no prompt from the user. Whether or not the files actually send is still a roll of the dice. You can leave the warning option on and then never see the warning message in the lobby because the transfer is straight up not happening.

Still saves a lot of time to rejoin, I didnt say its perfect.

In either case, if you don’t get a prompt and/or download, you still have to leave and rejoin until you do.

If you leave the warnings on, if you see the prompt then you can expect the file transfer to be coming next. You also get a prompt for each mod that needs to be downloaded (e.g. one for the map, one for the ai, etc). The transfer can still fail and the transfer can also just not happen despite the prompt. The benefit here is, if you don’t get the prompt you know you are screwed and need to rejoin.

If you deactivate warnings, the game does not prompt you to download. If you get the download then you’re set. If you don’t get the download automatically then you just sit there wondering if the transfer is going to happen or not.

Removing the marker also helps a lot for restoring issues

Well after i learned about the marker, I finally can restore games again. Since i simply wouldnt get a prompt and thus would not be able to download the file.

Now everything works perfectly. This definietly needs a change

Edit: This issue still persists with the latest update 36906. Players are still getting kicked if they ready up in UGC-lobbies.

Hasnt changed at all, alltough I have a mod for a mappack, the map still has to be transfered from the host everytime.