"Protector of the Realm" acheivement not triggering

:arrow_forward: GAME INFORMATION

:point_down: These details are CRITICAL; DO NOT skip them or your issue may not be reviewed.

  • GAME BUILD #: ######
  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED

The steam achievement “Protector of the Realm” from “Star of the Poles” in the Jadwiga campaign isn’t triggering. To receive it, you are supposed to win the scenario without letting any of the 3 neutral towns fall to the enemy. I have done this successfully twice now, but have not gotten the achievement.

:arrow_forward: FREQUENCY OF ISSUE

:point_down: How often does the issue occur? CHOSE ONE; DELETE THE REST!

  • 100% of the time (ALWAYS)

:arrow_forward: REPRODUCTION STEPS

:point_down: List CLEAR and DETAILED STEPS we can take to reproduce the issue ourselves… Be descriptive!

Here’s the steps to reproduce the issue:

  1. Start up Age of Empires 2 DE on Steam
  2. Play the Jadwiga campaign’s second scenario, “Star of the Poles”
  3. Win without any neutral towns falling to the enemy
  4. ?

:arrow_forward: EXPECTED RESULT

:point_down: What was SUPPOSED to happen if the bug you encountered were not present?
I receive the achievement

:arrow_forward: IMAGE

:point_down: ALWAYS attach a PICTURE (.jpg, .png, .gif) or VIDEO (.mp4, YouTube link) that highlights the problem.

:arrow_forward: GAME FILES (SAVE / RECORDING)

:point_down: Attach a SAVE GAME (.aoe2spgame) or GAME RECORDING (.aoe2record) of the match where you encountered the issue. Link it below if using an external file service.

I tried to upload my replay, but I guess I’m too new of an account.


Had the same issue. On a side note, the achievement “Malevolent Marauder”, from the Bohemians campaign seems to be bugged as well.

Same issue.

Note : I did do the secondary objective of converting the pagan lithuanians, triggering their villages to turn hostile until I destroyed their pagan shrine. If having them turn hostile prevents getting the achievement, there is no way of knowing it by reading the achievement description.

I have the same issue as well.
Play in standard, moderate and hard. prevent the enemy from knocking my castle downs
destroy the pagan Lithuanians before they turned nasty.

Build the castles around the flag as well, still cannot trigger achievements.
Waste a lot of my time repeating it.

Same issue here - Built all of the castles and didnt lose any, converted green and had them attack me (then subdued them), and finally killed yellow.

What’s weird is the Microsoft / Xbox exact same achievement triggered, but not the steam achievement. This leads me to think I’ve done it right but steam achievement is broken. Annoying since I’m going for all achievements on steam.

Thanks for the report, this issue is being tracked now!


Also had this issue. Please fix soon.

I got it today after just starting AoE (I finished it before but it didnt trigger then)

The achievement works now. I had to play it again, though, it didn’t trigger automatically like “Malevolent Marauder”.