Purchased dlc's for AOE 3

Purchased DLC’S for AOE3 but cannot access them.

1 Like

Are you on steam or Microsoft store ?


I am on Steam; they show up in my library but I cannot download or access them,

weird, tried restarting steam maybe?

If you right click on AoE 3 de on your side bar library, navigate to DLC and see if they are equipped. You might have to go to properties to check. If they are I would log out of steam and restart steam and try again

Hi! I had the same problem with DLC. (Microsoft Store not Steam, but maybe the following will work for you too.)
Try to log out from your player profile within the game. Restart the game and log in again. This worked for me. Hope I could help.

See here: https://support.ageofempires.com/hc/en-us/articles/4402286250900-Trouble-downloading-an-Age-III-DE-DLC

They don’t require additional download; everything is already included for everyone, otherwise multiplayer wouldn’t work.

To be clear, you mean you cannot access the civs that you bought? Note that none of the DLCs include campaigns.

Here the same issue.
I’ve bought the complete AoE3 DE bundle incl. USA civ. (on Steam).
Until yesterday all was good. But since today I’ve no access to USA anymore. All other extra DLC civs working. Restarting Steam client useless.
Who messed it up? Probably Steam client - since it got an update today.
Hopefully gets fixed soon.

1 Like

Me sucede lo mismo, hasta hace unos días todo funcionaba bien pero ahora al entrar al juego me sale que no tengo el DLC

i have a theory with USA dlc, also dealing with this problem myself
it must be related to it being both purchase and timed unlock, because only USA dlc suffers from this