Qormi-Mdina didn't give reward? Game crashes when editing Hometown with Ottoman ally in Valletta (Malta)

:arrow_forward: GAME INFORMATION

:point_down: These details are CRITICAL; DO NOT skip them or your issue may not be reviewed.

  • GAME BUILD #: latest
  • GAME PLATFORM: Microsoft Store
  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED


I just completed the first event with the Maltese. I didn’t received my reward. I don’t know if it’s a profile picture or an Explorer Outfit. Nothing is happening when I want to edit the Explorer either it’s Maltese, Italian, Spanish, British and so on. Simply clicking at Explorer but nothing happens.

I wanted to edit my hometown as well but as soon as I selected Ottoman ally the game crashed me back to desktop everytime. This time I don’t have any mods except Map mods activated.

EDIT: Completed Mdina. Same problem.

:arrow_forward: FREQUENCY OF ISSUE

:point_down: How often does the issue occur? CHOSE ONE; DELETE THE REST!

  • 100% of the time / matches I play (ALWAYS)

:arrow_forward: REPRODUCTION STEPS

:point_down: List CLEAR and DETAILED STEPS we can take to reproduce the issue ourselves… Be descriptive!

Here’s the steps to reproduce the issue:

  1. Play the event and finish it
  2. For the other problem, do what I reported above

:arrow_forward: EXPECTED RESULT

:point_down: What was SUPPOSED to happen if the bug you encountered were not present?


:arrow_forward: IMAGE

:point_down: ALWAYS attach a PICTURE (.jpg, .png, .gif) or VIDEO (.mp4, YouTube link) that highlights the problem.

:arrow_forward: GAME FILES (SAVE / RECORDING)

:point_down: Attach a SAVE GAME (.aoe3Ysav) or GAME RECORDING (.aoe3Yrec) of the match where you encountered the issue. Link it below if using an external file service.


Here nothing happens when pressing “Kundschafter” explorer. This is also happening with Italy, Spain, Britain. The others I haven’t checked it out yet.

Proof of the crash back to desktop. Probably could happen with other characters too. (Recorded with XBOX Game Bar)



Aztecs (working fine)

Mexico (working fine)


Hi, thanks for you report. Could be a Steam synchronization error. Try fully logging out of Steam and Microsoft accounts, and then restarting Steam and logging back into everything. If that does not work, let me know!

How can I do this on Microsoft Store? Do I have to logout of Microsoft Store and XBOX or just one of them, since I use the Microsoft Store version?

Edit: I logged out of Microsoft Store with automatically logged me out from the XBOX app as well. Then signed in and get into the game.

Everything is still the same. Game crashes when I want to make the Ottoman Ally at the Fort and no reaction when clicking on the Explorer. Everything is like I posted in this thread :frowning:

Do you have any mods running? Be sure to disable all of your mods, and try to verify game integrity! Let me know if you still have issues after doing so.

1 Like

Hey @DedeKorkut93636! Have you tried to uninstall and re-install the game?

Another thing that could help is to go to C:\Users\<user>\Games\Age of Empires 3 DE, find the folder that is named as numbers - that is your user ID. Send me that number and we can check your server stats to verify the unlocked Explorer skin.

Then, you can make a copy of that folder - delete the original and then copy-back only the data you wish to restore such as “homecity”.xml & “savegame”.age3Ysav files, located in C:\Users\<user>\Games\Age of Empires 3 DE\<userID>\Savegame. Be careful if you complete this last step as to not lose your data!

1 Like

Unbelievable, that this was caused by the Chinese Texture overall visual mod. After I deactivated it, the explorers where there as they should be!

But there is one problem:

I did take at that Women’s Day Event. I wasn’t able to complete all of the challenges but afaik I’ve unlocked at least one Explorer for the British. But it is locked.

Is there a way to see the past ingame event progresses? Will you make past events available again? I’d like to unlock Montezuma Explorer and many others, which I’ve missed

Hi @DedeKorkut93636! For the issue with the Women’s day Event, We will need your user ID so we can verify your unlocks for you!

1 Like

Dede Korkut 93

The one I use to play. I don’t know why it’s different here in the forums.

Hi @DedeKorkut93636.
Go to C:\Users\<user>\Games\Age of Empires 3 DE , find the folder that is named as numbers - that big number is your user ID. Send me that number and we can check your server stats to verify the unlocked Explorer skin.

1 Like

The folder I’ve found in that path is:


Hope this is helpful.

That’s what we were looking for, thanks!

1 Like

Hello @DedeKorkut93636, we’ve checked your account and found that there was no record of completing the challenges required to unlock the British Explorer skins during the event. Despite this, we have unlocked both of the British Explorer skins for you! :tada:

1 Like