Quick game. Lobby hangs

:arrow_forward: GAME INFORMATION

:point_down: These details are CRITICAL; DO NOT skip them or your issue may not be reviewed.

  • GAME BUILD #: 101.102.13221.0 #78757 10725973
  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED


Quick game lobby: matchmaking is done, but lobby hangs.

:arrow_forward: FREQUENCY OF ISSUE

:point_down: How often does the issue occur? CHOSE ONE; DELETE THE REST!

  • 25% of the time / matches I play (RARELY)

While writing this topic i tryed to reproduced the bug and it happened 2 of 6 my quick games.
Strange, but it happens in quick games, but not in rated games.

:arrow_forward: REPRODUCTION STEPS

:point_down: List CLEAR and DETAILED STEPS we can take to reproduce the issue ourselves… Be descriptive!

I have no clear instruction to reproduce.
Seems it depends of window focus.

  1. Start quick search.
  2. Alt+Tab to chrome (play chess, watch twitch, any you like).
  3. Wait for tray icon of aoe2de shows “game is found”.
  4. Click to aoe2de tray icon.
  5. Alt+Tab back out of aoe2de.
  6. Wait.
  7. Alt+Tab or click into aoe2de.
  8. Wait
  9. Repeat 5-8.

:arrow_forward: EXPECTED RESULT

:point_down: What was SUPPOSED to happen if the bug you encountered were not present?

No hangs.

:arrow_forward: IMAGE

:point_down: ALWAYS attach a PICTURE (.jpg, .png, .gif) or VIDEO (.mp4, YouTube link) that highlights the problem.

:arrow_forward: GAME FILES (SAVE / RECORDING)

:point_down: Attach a SAVE GAME (.aoe2spgame) or GAME RECORDING (.aoe2record) of the match where you encountered the issue. Link it below if using an external file service.

Not relevant.

Hi @CeratedCupid745
I tried to reproduce this issue but couldn’t. Could you check your ram consumption at the time this happens?
Thanks for the report :slight_smile:

Hi. I tried today. But this bug happened 0 of 3 times, so I cannot give you any screenshots of ram consumption. Previous times when this happened, i checked memory usage/network usage/ping to figure out any possible troubles on my side. Memory usage was in 5.6-7.0 of 8 gb, it’s normal for my machine. Ping was <100ms and stable.

Hm. But today some similar happened in ranked queue (all described above was only about quick games).

Me is the only player without “ready” checkbox. I waited for 10 minutes in this state and alt+f4. App does not hang, but the only you can is alt+f4.


Any mdump file?
“C:\Users\USER\Games\Age of Empires 2 DE\logs”
Something that looks like this “AoE2DESteam-58115-2022.01.19-15.05.33.mdmp” but with current build number and date.

Hm. I have no mdmp files since February in
…\Age of Empires 2 DE\logs
Is it ok? For me seems strange.

…\Age of Empires 2 DE\logs\SlowLog
contains some txt, but no mdmp

Are you using quick play to play against other players? If so: Please try ranked. Maybe you dont have the issue in ranked games.

Ranked games works exactly the same with the main benefit it uses a rating to try to match equally skilled players. As result games are even more balanced (and thus more fun)! Waiting times in ranked are also much quicker, because more players are playing in ranked, since there isnt really any benefit of playing in quick play.

Yes, this issue is only about quick games. Yes, I play more ranked. Thank you for advice.