Random Crashes and Terminating the game

:arrow_forward: GAME INFORMATION

:point_down: These details are CRITICAL; DO NOT skip them or your issue may not be reviewed.

  • GAME BUILD #: Hotfix 53347
  • OPERATING SYSTEM: Both Windows 10 and Proton (Linux)

:arrow_forward: ISSUE EXPERIENCED


Random Crashes mid game. And It terminated everything. The logs however say -

[rlink - error] 2021/09/22 22:16:25.315 (UTC) XboxPlatform::SetPresence not successful: XboxLiveContext is null

[rlink - error] 2021/09/22 22:16:36.264 (UTC) Unknown presenceID entered

After this there are the usual terminating logs. Also these logs appear even when there are no crashes so not sure if they are related but there is nothing noticeable except these logs.
I am experiencing this since 2-3 months and similar reports/logs on reddit. I hope this gets fixed soon.

:arrow_forward: FREQUENCY OF ISSUE

:point_down: How often does the issue occur? CHOSE ONE; DELETE THE REST!

  • 50% of the time / matches I play (FREQUENTLY)

:arrow_forward: REPRODUCTION STEPS

:point_down: List CLEAR and DETAILED STEPS we can take to reproduce the issue ourselves… Be descriptive!

Here’s the steps to reproduce the issue:

Playing the game either online multiplayer or offline.

:arrow_forward: WORKAROUNDS TRIED

  1. Subscribing/Unsubscribing all mods
  2. Clearing game data that is
    on Windows - Games\Age of Empires 2 DE\my-user-id\profile\ and also /saves
    on Linux - .steam/steam/steamapps/compatdata/813780/pfx/
    These folders ofcourse regenerated but bug still presists
  3. Removed all launch options and options like HUD.

:arrow_forward: EXPECTED RESULT

:point_down: What was SUPPOSED to happen if the bug you encountered were not present?

I should be able to complete a 3 hour game.

:arrow_forward: IMAGE

:point_down: ALWAYS attach a PICTURE (.jpg, .png, .gif) or VIDEO (.mp4, YouTube link) that highlights the problem.


:arrow_forward: GAME FILES (SAVE / RECORDING)

:point_down: Attach a SAVE GAME (.aoe2spgame) or GAME RECORDING (.aoe2record) of the match where you encountered the issue. Link it below if using an external file service.

  • NA

Hey @SHuRiKeN1812 ,
i am unsure i understand your issue, you get a crash only when you do all of your reproduction steps? Otherwise the game doesn’t crash? Did you try verifying your game on steam or reinstalling it?
Thanks for the answers.

Sorry my bad, I have added to the markup and made things more clear.

Oh, ok, thanks for the clarification. Have you try verifying your game on steam or reinstalling it?

Yes I have tried that. Once it just downloaded some kb of file. I am trying to debug myself right now…

Ok, in that case for proper investigation we would need crash logs or minidumps files. Do you know where to find them?

in the logs folder the .txt files ?

exactly, you can also add the recorded games :slight_smile:

Do you need the Age2SessionData ? Also I have a query (just curious) maximum how many dates (log files) are stored for ?

you can add that as well. I am not sure tbh 11.

Sorry for the late update, it was a problem with AMD drivers… was fixed with mesa update on proton and AMD driver update on win… It was likely due to a validation error.

I’m having the same problem. I have an Intel processor. No graphics card. Same error on log. I’ve already updated every single driver I could find, included .NET Framework, DirectX 12 and so on…

Can you please elaborate on what you did. I ran out of fixes.