Random crashes - Steam

So this is a bit of a weird one. I have 63 hours played in the steam version of the game with absolutely zero issues until yesterday. All of a sudden I’ve been experiencing all kinds of random crashes. If I click the multiplayer shield 80% of the time it will black screen and crash the game (Black screen won’t go away have to close via task manager but I’m still in control of the AOE mouse cursor). If I do manage to get into the lobby browser they will take a long time to populate or sometimes not at all and the “searching for games” icon will just keep on spinning.

If I try to create a lobby then the game will instantly hang and stop responding. When I manage to get into someone else’s lobby then any pop up screens (Civ selection, Tech tree) can cause the application to hang, as will switching colours or teams. The game will usually eventually start responding again if I click wait.

During a game anyone resigning will cause the game to hang again, clicking wait sometimes resolves this and sometimes the game will just crash to desktop.

As far as I can tell this happened completely out of the blue with no changes to my system at all. Nothing was installed or removed and nothing was updated on the game. One day it worked perfectly and the next it didn’t. If anyone can give me any idea on how to fix this I’d appreciate it.

System Information
OS: Windows 10 1909
GPU: GTX 1070
CPU: i7-6700k
RAM: 2x8gb
Game Version: Steam
Anti Virus: AVAST free

I’ve followed the troubleshooting guides on both Steam and on here to the letter. No error logs exist anywhere (Appdata folder nor C:/games folder). The windows event viewer just shows an application hang error for the game.

I’ve uninstalled (and manually removed all folders) and reinstalled twice, once to my normal C drive and once to my D drive. Both installs have the same issue.

I’ve disabled and removed all mods I had installed (I think just small trees was all I had)

I’ve tried manually increasing my page file limit from 8gb to 16gb on both my C and D drives which did not resolve the issue.

I’ve tried using various display modes (Full screen/windowed etc)

I’ve double checked all my drivers are up to date, my GPU drivers were updated and this didn’t resolve the issue.

I’ve tried signing out of Xbox from the main menu, this didn’t help either.

I disabled my anti virus and loaded the game, no change.