Ranged units unable to build rams (campaign)

Spears and MAAs are able to build Rams (right). Crossbows are unable to (left)

1 Like

Hi @BrianLinOnline, This may be a limitation of the campaign mission. Are you able to use crossbowmen to build rams in other game modes?

Hi @RadiatingBlade

I was only able to replicate this bug in the Rus campaign - the XBs were able to lay the foundation for a ram, but not complete it. Every other unit appears to be able to build the rams. I don’t think that this is an issue in multiplayer, but I’ll make a post if I see that.

I had the same issue when trying to build rams in the French campaign with archers. Maybe this affects all archery range units.

I experienced this in the french campaign. Infantry was able to place blueprints, but when building the siege it did not show any progression. However, after placing the blueprints with my infantry, my cavalry was able to finish building the siege.

@MerstinSteel @Floorinho

Can you replicate this with different archery range units? I was able to use the Rus campaign musketeers to finish building the rams after laying the foundation with XBs.

Also, you were able to build rams with your cavalry?

I loaded my save from there and could reproduce the issue. It was in the siege of Orleans mission. As you can see from the screenshots, Archers and Crossbows can create blueprints but do not start building the siege. When I use knights it starts building. See attached screenshots:


In the Orleans campaign where I experienced this bug, I tried to build rams with different units, and here are my findings:

  1. The rams get built without any issue with all barracks units (spearmen and men-at-arms). The build animation (the spearman rotating his spear) occurs and the ram progresses in HP.
  2. Both archers and arbalesters are unable to build rams. They go next to the ram but before the build animation kicks in, the unit just stutters and it is unable to begin ram building. To me, it appears to be a unit-pathing-related bug. It is the same kind of stuttering I see when lots of units are standing in close quarters and are unable to get to a rallying point because there are other units occupying their spot. I don’t mean to send you down a false trail but maybe this would be a possible place to start looking for bugs.
  3. I was not given the option to build rams with cavalry units. Not sure why.

Both times I saw it, I used a loaded save from that campaign. Perhaps that is the difference?

In the great wall campaign as Mongols, I was unable to build rams and siege towers to destroy the great wall.

I had Siege engineering researched, however when I drop the rams the units start building it and the HP of these just stays at 1/1000 and does not increase.

Eventually I thought the game was unwinnable as the units I had on field could not attack the great wall gate. I had to finish the campaign by dropping 15 outpost towers in front of the gate and attacking the gate.

I am not sure it got glitched in the recent patch? Please investigate.

I just completed and was able to build rams with spears.
As a test, did you try a different unit to complete the rams?
Was your population maxed? I believe each ram take up 2 population.

What I found shocking is that I had spears start the rams, but my Mangudai unit group completes the rams much faster (you think the horses would take up more room). Spears don’t crowd around the rams as easily where a large horse unit does - not sure if this is intentional.

@PoutyAlpaca4190 I also was unable to repro this, but I will keep an eye on this thread. If you (or anyone) has this crop up again, please mention it!

Is there a way I can send you recorded game files? Maybe that helps to figure this out. I am not sure if this issue occurs when doing the campaign across patches. Basically I think I started the campaign long ago, and I continued after the siege of the first castle to go on to Great wall part. It was not a saved game though. I just clicked on campaign and continued.

I have not yet tried to redo the campaign to see if the issue persists again.

Mangudai are not supposed to be able to build rams right? Its only meant for infantry no?

I am going to try the campaign again with rams. But I think there should be special achievement for destroying great wall with just Outpost Towers! LOLL

Once the infantry start to build a ram, they can leave it and the Mangudai can finish them faster than the infantry I’ve found. Not sure if this was intended or a bug.

I was able to reproduce this in a different campaign mission. Archers and Crossbows could lay the foundation but building did not succeed. Knights were able to finish the foundation though. Please see Ranged units unable to build rams (campaign) - #6 by BrianLinOnline

Thanks, all! Appreciate the extra details. We’ll look into it.