Ranked online games slow to unplayable stutter after patch

:arrow_forward: GAME INFORMATION

  • GAME BUILD #: 101.102.15522.0 (#81058) 10944061
  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED

I’ve only played ranked games since the patch came out (both 1v1 and team).

Each time, after the clock hits 30-40 minutes in-game, the game begins stuttering. It doesn’t accumulate lag, it just suddenly goes to about 1 second of regular speed vs. 5-10 seconds of frozen. During that one second I can try to issue commands, and they get through maybe 1/5 times. When they don’t go through they don’t seem to be buffered, just ignored. (One way to see this in particular is that chat messages I type, when they eventually appear, will have some but not all the characters I entered.)

Oddly, other players say they aren’t experiencing lag, and my connection icon in the game doesn’t turn yellow or red. In other words, from their point of view, it’s like I’m AFK.

:arrow_forward: FREQUENCY OF ISSUE

  • 100% of the time / matches I play (ALWAYS)

:arrow_forward: REPRODUCTION STEPS

Here’s the steps to reproduce the issue:

  1. Play a ranked game and have it last 40 minutes

:arrow_forward: EXPECTED RESULT

Game continues at regular speed as normal.

:arrow_forward: GAME FILES (SAVE / RECORDING)

Example where this happened (I’m p6). The stutter sets in at about 43 minutes, hence my production becomes sporadic. I swear I was trying to build siege workshops and transition into a counter :')

The message around 46 min, ‘ane lag’, was typed as ‘insane lag’ but the first few characters were not registered.

In the end I have to quit the game I’m handily winning. Note that I had to alt-f4 since when I tried to resign, the yes/no dialogue would come up, but pressing yes would dismiss the dialogue without it actually resigning me.

MP Replay v101.102.15522.0 #(81058) @2023.04.16 122121 (1).aoe2record (3.6 MB)

:arrow_forward: LOG FILES

2023.04.16-12.17.59.txt (23.4 KB)

Since there’s no actual crash I guess I don’t have an .mdmp file.

Update: It happened again and I tried alt-tabbing and turning off all features of my Malwarebytes Premium antivirus (version 4.5.26). The game recovered. Maybe something about this new patch triggers excessive real-time scanning?

This problem might come from your antivirus. Try adding the whole folder of the game to the antivirus exception list. You’ll have to do this after every new update.


Thanks. That aligns with my experience. No patch had done this to me before but I guess it can strike pretty randomly.