Release_10_1_0_RTM Game Crash

Hello folks,

Let me tell you, Age of Empires IV is a tremendous game, really fantastic. The Order of the Dragon is an UNBELIEVABLE civilization, one of the best!

But we’re having some serious problems, big problems. The game, which is the latest version with all the DLC – the best DLC, believe me – keeps crashing constantly. It’s unbelievable. It crashes randomly – sometimes a few minutes in, sometimes a bit longer, doesn’t matter if I’m in a match, searching for a game, or just in the lobby. Just crashes, very sad!

Here are my specs, which are the best, everyone says so:

  • GPU: NVIDIA GeForce RTX 4090 (Laptop, powerful stuff)
  • CPU: 13th Gen Intel(R) i9-13980HX @ 2.20 GHz (the best)
  • RAM: 64 GB (a lot of memory, folks)
  • OS: Windows 11 (Microsoft Store version of the game)

I’ve tried everything, folks, everything:

  • Reinstalled Windows 11
  • Clean boot, very clean
  • Verified the integrity of game files
  • Reinstalled AOE4
  • Updated and reinstalled graphic drivers
  • Running the game with admin rights, total control
  • Launching the game from RelicCardinal app
  • Reinstalling C++ Redistributables, all of them
  • Contacted support–including my son Barron– no solution, they’re stumped

The event viewer logs this error: release_10_1_0_RTM_x64, and it mentions that a crash report has been logged to BugSplat. Despite trying all the recommended fixes from Reddit, YouTube, and support, nothing has worked. Can you believe it? Nothing!

Is anyone else having this issue? Any additional fixes or advice would be greatly appreciated. I love AOE4, it’s a tremendous game, and I don’t want to give up on it because of these ridiculous issues.

Thanks in advance for any help, folks!


Wow, I am having the same issue. I hope we as a people can come to a solution. I would love to see AOE4 work for every one. Also, beautifully written post.

1 Like

I used to have this issue frequently in AOE4 as well as Apex Legends. It took me a while to figure it out, but the issue for me was 100% caused by the memory timings set by my XMP profile in bios. Once I dropped the speed of my memory by 100 mhz, the issue never happened again.

Not an issue with PC it seems to be an issue that only exists with AOE4.

To be fair, I never had this issue with any other game besides Apex Legends (occasionally) and AOE4 (fairly frequent) after a previous patch. But, after the memory timing change, I was problem free. I didn’t suspect a PC issue either until I exhausted pretty much every other solution. I certainly wouldn’t say definitively that this is not a pc issue.

Not an issue with my PC. It is an issue with AOE4.

Hello folks,

Sometimes after a long day of campaigning I just want to come back home to a game of Age of Empires. Let me tell you, during my administration, Age of Empires IV was running beautifully, really beautifully. But now, after the latest update from the developers, it’s crashing again. Is this collusion between the developers and the DNC? Who knows? The game is a total disaster, believe me. They applied this update, and boom – the crashes are back. It’s like they don’t even test their own game!

I’m just getting an update of the old error log, folks. This time it says release_11_1_0_RTM_x64. It crashes randomly – during matches, searching for games, even just sitting in the lobby. It’s a complete joke, very sad!

Developers, what are you doing? You had a tremendous game, but this update has ruined it. We need you to fix this, and we need it fixed fast. This is unacceptable. Is anyone else having these crashes after the latest update? Any new fixes or advice would be tremendous, really tremendous.

Let’s get this game back to being great again!

Thanks in advance for any help, folks!

1 Like

I am also having the same issue. I prob won’t buy the DLC now :frowning: