Replays shows player info from a different match, plays replay from yet another match

When I go to review a replay, I click on the latest replay and a completely different replay ends up playing instead.

I click on the latest game I played, which was a Black Forest Map against Player 1:


The map appears correct. However, I see the matchup for a completely different player, Player 2.

When I click the replay button, the recording for a completely different map (Archipelago) and player (Player 3) ends up playing instead!

The replays were working fine as of Sunday.


I have the same issue: Replay not replaying the correct game

1 Like

I posted the same thing yesterday, A game restart fixed it for me.


This has been a permanent issue for me since launch. Restarts not helping.

1 Like

Last Night’s Attempt:

  • – Had the issue last night, but had been drinking and thought I misclicked.

Today’s Attempt:

  • – I played one match today (2v2). After about 5 minutes after the game finished, I clicked Replay (for today’s 2v2 match), however, it took me to my very first game from yesterday (a 1v1 match).
    • – I’ve only played 3 games total (two 1v1s yesterday, and a 2v2 today)
    • – I also double, and triple checked
  • – After noticing it was the wrong match, I exited, then tried again (took me to the same first match from yesterday).
  • – Then I clicked down the list of matches (only two others to choose from [1v1s] => both matches replayed correct match).
  • – Then I clicked replay on the most recent [2v2] match again and it played my first match from yesterday again [the 1v1].

  • Before Creating my account on here and submitting this post – thought I’d check one more time (for
    S&Gs) [after about 20-30 mins after my third game ended] - still same issue.


Ah, so I just restarted AOE4 (exited to Desktop and then executed application):

  • – When I go to history and click on the match (right before hitting replay), I can now see all 4 players that were in the game – (previously I could only see myself and my teammate [was a friend/group joined quickmatch]). I just clicked replay and verified that it’s now showing the correct match.


  • – It appears that maybe the replay defaults to first match if that replay does not exist?
  • – Maybe the match was not ready to be viewed yet (though the game exists in my client history and is recorded on the server – the match replay [file] itself was not ready – so maybe some sort of event listener or callback stating that the match is not ready to be viewed with a button to ‘refresh’ would be a good implementation for this issue (or without the refresh button and just wait for a callback from the server when the file is ready for download… or both)

Love this game though! Haven’t played since AOEII - and this feels really good.

1 Like


this is bugged for me aswell. when can we expect this to be adressed?

please add this to known issues:

When select a replay to watch I do not get the expected replay. For example, in the attached image, I wanted to watch a replay of my latest 2v2 game. Instead, when I press play, I get a 4v4 from several days ago. Additionally before watching the replay the information about the game (map and number of players) is correct but the player names below are incorrect.

1 Like

Another user with the same issue. Replays shows player info from a different match, plays replay from yet another match

Thanks all! We’re aware of this one and tracking it internally.

When I click on the latest match to watch the replay, it opens another game I played in the past. Has anyone encountered this issue?


yes its a bug, you need to restart the game, then its correct

Thank you for confirming👍

yep, i’ve to the same issue. Even downloading the replay after clicking most recent game opens the replay for another game. Restarting fixes, but it’s a bug as you shouldn’t need to restart

Replays may load the incorrect game.
I noticed this after I won a 1v1 quick game and went looking for its replay.
The replay description was correct (Surrender Victory, Standard, Hill and Dale, 1v1Standard)
However the player slots reflected a copy of a 3v3(Coop vs AI) game I played last week. And surely enough, loading this replay resulted in that same 3v3(Coop vs AI) match.
This most recent replay was the only one which was incorrect in this way.

Even the match history of a player it loads the wrong game too ,so devs please fix this asap

Restarting the game usually fixes it

But still it is a very annoying bug

I too have this problem. I have played 20+ games but can only watch one replay. No matter which match history game I click on it always shows the summary and replay of the first multiplayer game I ever played.

Thanks, all! We are aware of this one and working on it. Appreciate the reports, though!


If I look at my match history to look at the replay from my last game it’s not the one I just played. It’s a completly different match.