Revolution button missing on all civs

:arrow_forward: GAME INFORMATION

:point_down: These details are CRITICAL; DO NOT skip them or your issue may not be reviewed.

  • GAME BUILD #: 100.12.54545.0
  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED


The revolution button should be inside the TC menu, but is not, no matter what kind of settings used for the match. This happens for all applicable civilizations, not only Spain (see picture). So far have tried:

1 - Uninstalling mods
2 - Changing settings (startin/ending age, game mode, game rules and maps)
3 - Verifyin cache with Steam
4 - Unistalling and installing the game
5 - Changin options (UI, layout, graphics,etc…)

Nothing have worked so far.

:arrow_forward: FREQUENCY OF ISSUE

:point_down: How often does the issue occur? CHOSE ONE; DELETE THE REST!

  • 100% of the time / matches I play (ALWAYS)

:arrow_forward: REPRODUCTION STEPS

:point_down: List CLEAR and DETAILED STEPS we can take to reproduce the issue ourselves… Be descriptive!

Here’s the steps to reproduce the issue:

  1. Select any civ that can use revolution in Skirmish
  2. Upon starting the game, the revolution button is not present at all in main TC menu

:arrow_forward: EXPECTED RESULT

:point_down: What was SUPPOSED to happen if the bug you encountered were not present?
Revolution button would be present in TC menu, but greyed out if not in age IV

:arrow_forward: IMAGE

:point_down: ALWAYS attach a PICTURE (.jpg, .png, .gif) or VIDEO (.mp4, YouTube link) that highlights the problem.

:arrow_forward: GAME FILES (SAVE / RECORDING)

:point_down: Attach a SAVE GAME (.aoe3Ysav) or GAME RECORDING (.aoe3Yrec) of the match where you encountered the issue. Link it below if using an external file service.

Hi @Ricaba!

We cannot reproduce this issue.

Was the ending age Imperial? If it was not, then it is okay.

I reproduce your problem only by putting the ending age at fortress so maybe you need to put the ending age at imperial on your lobby yeah


I just double checked my settings and the ending age was Imperial Age. See screenshot below before and after hitting play.

Still no Revolution button on TC.

Anything else that I should check or change?


I just replied IkoKnight8151 with this. I have Imperial Age as my ending age, you can see more screenshots on the thread.

Thanks for the reply though.