"Servants of the Land" Achievement: Not Bugged - Explained

I’ve had multiple games of using plain Landsknechte (not elite) armies, killing thousands in each game, and only using that unit (supported by Prelates). I distinctly recall games with 1K, 2K, 2K, and this one with 8K. That’s well over the 10,000 kill requirement for the “Servants of the Land” (Kill 10,000 enemies with Landsknechte) achievement. What am I doing wrong? Does it need to be in a single game? Do they need to be elite? Does area damage not count, and only direct contact kills count? Are they not allowed to be buffed? I’m completely lost here

No games were saved/loaded
Spread across first and patched versions (this screenshot is from the 7989 patch)

Hi @Th3Cyb3rGuy, Would you be able to attach a screen capture of your current achievement progress for this particular achievement?

/sometimes it does require the regular unit… one other poster stated the upgraded unit didnt work for them.(regarding a different achievement i believe). using the analogy “kiss” keep it simple… just smash them with the straight regular landsket. And yes it does always have to be all in one battle


Here you go @RadiatingBlade ! I’ve noticed that none of the achievements show progress…they just pop when you meet the criteria. Notice the “through the ages” has no progress, but I have the masteries completed…and I definitely aged up once or twice :wink:

Foreal? I did the 1,000 cavalry with camels and gunpowder units and such in multiple battles

I would be corrected then… try just the basic landsket then

No worries! And thanks so much for chiming in. If needed, I’ll try and crank out an 8-hour match, lol. Wish you could see how many kills you have during the match. And they are regular; I never upgraded them in the barracks. Just their armor and damage I also did that for the camel achievement, nest of bees, demo ships, etc)

Long match - make sure u got a good connection lol one bad drop and :rage: rage quit… lol i always yell… HULK smash !!

That’s how long it’ll take to get 10,000 kills in one match (if that’s how it’s to be done) without human grinding. Keep me posted if you hear of someone getting it successfully and how

Achievements in general are bugged right now. I just earned five without doing anything and others are doing what it takes to earn them and not unlocking them.

Copy - thanks for the follow up! It’s just strange since I only have those 5 left, meaning all are working fairly well for me. I’ll keep at it and let this thread know if I’m successful.

I’d be interested in anyone else who gets it done though

Probably wouldn’t hurt to log out log in restart router… anything to kick the system…

@Th3Cyb3rGuy Landsknecht HRE Mastery 9 - Incompletable if you upgrade them

@RadiatingBlade maybe join these two? :man_shrugging:

1 Like

Two things:

1 - I just finished it!! Still not sure why it took over 15K kills to register, but it took…thank goodness!

2 - @RadiatingBlade , you asked to see my progress. While Steam doesn’t track progress, Xbox does! Here’s a screenshot showing my progress on the Landsknechte and Aging Up ones. Hopefully we can spread awareness that, if linked to your Microsoft/Xbox account, you can see your achievement progress, down to the percentage.

Happy to have this thread merged with the other one, @Daiginn , if you’d like. I can verify the Landsknechte’s weren’t elite, I was able to upgrade them in the blacksmith, stats in the university, and buffed by the prelates - and they counted towards the achievement.

1 Like

Awesome tip!! :clap::+1: thats gonna be very helpful to alot of people

1 Like

It’s worth noting in challenge 9, do not upgrade the Landsknecht at the blacksmith before attempting to get kills, I tried this challenge several times and was baffled on how I could have killed 10,000 with the Landsknecht, but still not get the challenge for killing 50. Upgraded kills will not count toward the challenge.

Feature? or bug?

Worked just fine for me. Went Meinwerk → Burggraf and basically upgraded melee units before I even had my first Landsknecht out. Completed the challenge no problem.

But I probably did this challenge 7 or 8 times. Nothing. Building only the required units and Everytime, nothing.

It wasnt until I never upgraded them that it worked.

Did it both before and after patch and it didn’t work