Setup of PCs on LAN game only AOE 2 DE

Hello ,
how do we setup an old fashion LAN game on 2 Win10 PCs ?
Tried few settings in Local LAN , but it does not work

See attached setup of the PC attempting to host and pictures of message of a invited guest that is trying to join the lobby.

Any ideas ?



Try this.

1 Like

Thanks , I have looked at the pages and found one reference to LAN. Suggestion was to open TCP and UDP ports , which I have done on all PCs , reboot but it still does not work.

Q: Our internet connection sucks , does the game need good connection to internet for LAN games ?

Any other ideas ?


Are you trying tro play via physical LAN, like Ethernet right? If by real LAN your internet connection should not make a difference, since it’s a peer to peer connection (p2p) between both machines.

Could you provide more info on how the LAN was set up? And you tried to disable the firewall yet?

1 Like

Its not working for me.

  • Public IP address with DMZ on both sides (no CGNAT, nor ISP blocking [I work there])
  • No firewall (all down, on router and Windows, on both sides (to test))
  • Using the same version (Steam, both updated to the same version)
  • I have Visual Studio installed (I already had before this game, so I probably have ALL the necessary redists packages needed)
  • And Steam invites doesn’t work, I have to use the invites available on the game.

Is there any way to enable debugging information? All I see is this screen, and it doesn’t provide any kind of useful information.


We have not been able to make this work even with the latest update 101.101.34223.0 0

Were you able to make it work ?




Have you tried enabling/disabling UPNP With this tool ?

But first before using UPNP tool both of you should turn off windows firewall completely “temporarily”, then use the tool to disable/enable (try both) and finally run the game as administrator.

Also may I ask how are you guys attempting to LAN? are you using ethernet cable or connected to wifi to the same router because in both cases it counts like LAN. Still i need to know so i can help further.

As I said before, we did all of this, and nothing worked. We gonna completely reinstall the game to test again.

Edit: Although we did not use the UPNP tool, we just don’t need. With firewall down, public IP address (no CGNAT) and DMZ to our IP, there is no need to keep UPNP enabled. I’ll enabled just to make sure, but it doesn’t seems to be the case.

If this is a LAN Game, why would a Public IP / DMZ even come into this situation?


TL;DR: I was wrong on thinking that “LAN” would work as simply “direct connection” as does on other games. AOE2DE seems to use some discovery algorithim that will not work if you’re not on the same gateway (even with some basic VPN like the one built in on Windows). Using a OpenVPN server however, works fine, because you and the other host will share a common gateway.

Original post: We are not on the same network. I know what LAN means, but it doesn’t have any diference here, because it still end-to-end connection. We can play any other kind of game using “LAN” mode and putting our public IP address. In the end, it just “network”.

Edit 1: Now that you mention, it is possible that they implemented some “discovery” algorithm that works ONLY on LAN (and not on end-to-end connection). Strangely we do this on AOE2HD and works fine (with less than 20ms of latency, because we’re on the same ISP).

Be right back!

Edit 2: Bingo, it works with VPN. We didn’t had to do this with AOE2HD (and we aren’t using relay servers), it seems there is some new algorithm involved in AOE2DE. They could keeped the old algorithm. Too bad.

Edit 3: They clearly changed how MP works in AOE2DE. Meanwhile on AOE2HD.

DMZ disabled

DMZ enabled

The only way we can do this now on AOE2DE is by using a VPN, but it is not a problem for us.

Edit 4: Using a VPN connection with no common gateway (usually Windows VPN) doesn’t work. My bet is that the game is doing a broadcast to gateway to find the other peers. Using a OpenVPN server works fine.

S#### Microsoft, just let us put a direct IP and we’re fine.


Yesterday I was going to suggest Windscribe or VPNSTEIN V2 then i discarded the reply as i believed you would not be interested. Anyways in my opinion since the vpn fixed it only means that the router or one of your computers are not really opening any ports. OpenVpn windscribe or vpnstein those will open ports. A lot of players use vpn on voobly to fix fast proxy.

we have done a lot of experimenting over the weekend.
To start with we followed your instructions and turn off firewalls on both computers ( both are Win10 and LAN is wired connection here at home )

Once we disabled the firewalls we were able to connect to common LAN server lobby and launch the game. We played this game for several hours and it has not missed a beat. I saved the game to my PC as well.
The following day we tried again with firewalls off again and could not make a connection.
When I tried to load the previously saved game, it would not allow the second player to join.

Next day (today) we turn the firewalls back ON and tried to load previously save game and it loaded and player 2 was able to join right away.

We finished the game and didn’t have any glitches.

Soon as we finished the saved game , we tried to start anther LAN server game but no luck, second player could not join again.

My observation is that there has to be fast connection needs to be made with a some external server for the Xbox server to "verify the players credentials/ ID or something " and if that connection if not fast enough. second player has trouble of connecting to the lobby. Once this authorization is made with MS/ Xbox the game is “handed over” to LAN local server and everything seems fine. Same authorization needs to be done to join previously saved game. I could be totally off on this …

I really hope that LAN do not require server handshake because that would not make sense since LAN is supposed to be private and completely offline. have you guys try LAN without actual internet?

I had this issue with the windows firewall where i had to disable it to download apps from MS store and then later ms store is not working as i have to enable back the firewall.

I feel that this issue is related to windows installation. Before I made the upgrade to SSD just two months ago I had windows 10 but not a fresh install; I basically never formatted my pc since 2012.

I had windows 7 then I upgraded it to windows 10 and it remained that way a messy system so to conclude i believe that the firewall breaks down or “something happened” as microsoft used to say 11


You cannot play this game without internet. I tried and…

Thus, I leave this meme here:


“Placeholdertext” 1111111111111111


Limitations on the P2P connection are probably related to anti-piracy measures.

But the LAN requirement seems very odd to me. It can prevent some things like non retail VLAN access, but it’s just that. I don’t know if it is intended.

1 Like

Stupid Microsoft-style lan game, you need Internet connection to play a LAN game!!


Hey guys i have the solution, it turns out that the oficial page dind’t show us all the ports that have to be opened, so here are al the ports for the diferent versions:


And here I made a guide to open the ports and select them




I tried these settings and we both have the same versions of the game. One steam and 2 PC ones, and still no luck. Anyone got this to work consistently?

So, I just tried some other stuff:

  • new faster ISP
  • Another PC
  • Latest updates

Still get Unknown Error on LAN multiplier connection

1 Like