Several achievements not working

Frankly My Dear
Sushi lover - still not working after update
The King is Dead, Long Live the King - I won several Regicides but no credit.
Marco Polo - Spent a ton of time doing this and no credit.
Howdy neighbor - I’ve scaled walls several times…no credit
Rough Ride
maybe a couple more. I’ve gotten credit for 55 so some work for me.



good evening, same for me I explored everything on a derisoir card, because on steam it’s brand derisoir, I even did very little bah no success

Hello. I have the same problem. The ones that aren’t working for me is:

Renaissance Man - Complete the Sforza campaign
Master of the Maghreb - Complete the Tariq Ziyad Campaign
The Thicker the hay, the easier mowed - Complete the Alaric Campaign
Battle Beast - Complete All historical battles

I have done them all but I don’t get the achievements :confused:


good evening, for a game with the king I succeeded
for those who are not going, me yes I knew for the success of making a game with each civ bah in, made must do game in “random” also and the two other also complete random, the first tab where we have the same civ

good evening, for I had a good time with the campaigns, I had them all successful! Did you do all the missions without code avidly?

hello, also for Marco Polo
Explore 99% of a ridiculously small map.I’m on steam, well marked derisory does not work, I am very small, small 8 days still not them, I explore the whole map but each time I have 99% would be for her, that we don’t have 100%

good I succeeded, derisory card as indicated steam, I put myself in combat to death, card quoted, with option of the square line, I have them 99% valid success, I took the hun

Same here. Marco Polo, Out with a bang, Rest in Peace, Relic Hunter is stuck at 65, and homeless, all on Steam aren’t triggering for me. Also No Suntzu Light isn’t showing a counter so no idea how many I have to go. I tried the save and restore trick but still not achievement. Has anyone managed to get any of these working recently? I’ve tried standard games and multiplayer games with no luck.