Severe FPS drops

Hi guys,

I’m having problems running Age 2 DE on my laptop. I have an Intel CPU i7-7500U, and a NVIDIA GTX 950M video-card.

I should be able to run the game with these specs, but I’m experiencing severe FPS drops, even with all graphical effects disabled. I even tried to download some mods to further disable graphics, but it didn’t help much. Any normal Castle Age battle gives me 5 FPS.

What can I do? I did check and the NVIDIA Control Panel was assigning my dedicated GPU (GTX 950m) to run the game. I even tried to uninstall my antivirus. Any special mods to make the game run smoother? I feel very disappointed by the situation.

PS. Also, lowering the screen resolution gives me a terrible zoom level, which is almost unplayable (in my opinion).


they broke performance with last update. for me, on team games fps dropping to 2 after 40 minute. i can’t play any team game since anniversary update and hotfix. they don’t love there community, still waiting for a fix for 1.5 month. DEVS HERE OUR VOİCES PLS
940MX, i7-7500u 50-60 fps before 30 min, 30-40 before 40, 1-2 fps after 40 min


Same is happening to me, once everybody is in feudal age, a severe lag starts, and by castle age, the delay is of 20 seconds or so, unplayable, is the new update, they have to fix it up.


I have a much weaker system than you do and I only get frame drops in maps with huge forested areas like Black Forest and Arena.

1 Like

Hi @FoughtBird1976, thank you for your feedback.

I suffer drops to 5 FPS all time. I tried to play the last mission of Attila’s campaign without any luck. Perhaps the map was too big as you said.

Could you please share which antivirus you use, at which resolution you play, and if you have any mods installed.
Thanks in advance,

Hey mate, your CPU is pretty bad and this is most likely causing the problems for you.

Has your game always ran badly or only after updates as some have mentioned?


Is the CPU really that bad? I thought an Intel i7 CPU @2.9 GHz would run the game quite well.
This is quite surprising to hear, considering that the minimum recommended CPU is an “Intel Core 2 Duo or AMD Athlon 64x2 5600+” (both very old fashioned models). I even thought I was closer to the recommended CPU specs: “2.4 Ghz i5 or greater or AMD equivalent”.

This is the first time that I try to run Age 2 on my laptop, so I’m not sure about the effect of the updates. I used to play on a Desktop Gaming PC, but I moved recently to another country. In my Desktop PC, the game worked perfectly, even though its CPU (i5-4460) is actually slower than my laptop CPU on the majority of tasks. Starcraft 2 runs flawlessly, I’m not sure what’s going on :slight_smile:

Are there any mods to disable graphical effects almost to the level of the HD edition?

You should have brought the most important parts with you on the flight :stuck_out_tongue:

Yes I think it’s just because you have a pretty weak laptop.

I doubt it’s a graphical problem.

I think I found a solution actually.

My CPU temperatures were really high (90+ Celsius), so I limited the maximum CPU load to 90% (in the energy settings). Surprisingly, now the game runs smoothly. Perhaps the FPS drops occurred because the laptop halted the CPU activity in order to lower the temperatures, which makes sense. This created an erratic on-off behavior.

Either that’s the answer, or Starcraft 2 installed some C++ libraries which game the game run better :smile:

Now I’m ready to play the Lords of the West expansion :smiley:

1 Like

Yup CPU temp does effect FPS

Really weird you were getting that hot in AoE2 tho

1 Like

Yeah, it’s a bit rare to get such high temperatures. I’m not sure what’s going on.

However, I have read that some “ultraportable” laptop models reach temperatures in the 90°C + range all the time. I don’t think such temperatures are healthy nonetheless.

Anyhow, now we have a solution :slight_smile: