Shift + middle mouse button doesnt work as hotkey anymore

:arrow_forward: GAME INFORMATION

  • GAME BUILD #: dynasties of india dlc initial release
  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED

shift+middle button doesnt work as hotkey anymore, it can be assigned in the hotkey editor like always, but the function doesnt work.
e.g. shift + middle mouse button for select all military buildings.

:arrow_forward: FREQUENCY OF ISSUE

  • 100% of the time / matches I play (ALWAYS)

:arrow_forward: REPRODUCTION STEPS


:arrow_forward: EXPECTED RESULT

hotkey works like before the dynastiies of india dlc release

:arrow_forward: IMAGE


:arrow_forward: GAME FILES (SAVE / RECORDING)



Same here, please fix, unplayable for me :frowning: .

1 Like

Also Alt-Middle button is not working anymore. Really annoying. Please fix!

Same with shift mouse up and shift mouse down


Thanks for this, we are already tracking this issue!

1 Like

Me too, was my Select All Idles click. Hard to get used to a new one!

i have select all idle villagers: ctrl + middle button

not working anymore omg

my game updated today and this problem is still not solved.


same issue here and i also got my extra mouse button not working as hotkey

this is ridiculous. i cant play last couple of days.

1 Like

you can buy a mouse on which you can bind another key on mouse wheel up/down/middle.

it will be faster than devs fixing the issue.

My mouse has an extra button binded to a keyboard key and it’s also not working

1 Like

try shift + number. like shift + 9. not shift + numpad9.

To be more precise:

  1. Ctlr + Middle Mouse
  2. Shift + Middle Mouse
  3. Alt + Middle Mouse

All were working before update. But not working now.
Pure “Middle Mouse” click still working.

1 Like

Here is what worked as a temporary workaround for me: I used my mouse software to map the middle mouse button into a keyboard key. Then I changed all my hotkeys to use this key instead of the mouse. At least now I can play using hotkeys again.

bro i explained the same already.
devs won’t fix it before the next dlc ‘The Pacific’

that will ruin my windows experience.

bro obviously you unbind/bind it as soon as you close/open the game…

im too old for that bro