Snow, Foundation deletes layered terrain after re-loading file

:arrow_forward: GAME INFORMATION

:point_down: These details are CRITICAL; DO NOT skip them or your issue may not be reviewed.

  • GAME BUILD #: 101.101.54684.0 7486483
  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED

I’ve found a bug with using Snow, Foundation (ID #36) as a base terrain with other terrain layered on top of it.

The Snow, Foundation terrain always overrides any layer terrain put on top of it after you save and reload the game. That is, if I place some Snow, Foundation terrain as a base layer on the ground, then enable ‘Layering Mode’ and place another terrain, say Black, on top of that, then save the file, quit the editor, and re-open the file, the Black terrain will have disappeared.

I made sure all values were set to default in AGE, but that didn’t fix the problem. I then tried reinstalling AoE2 but the issue persists even after a reinstall and starting new scenario files from scratch.

I then tried placing some Snow, Foundation in a different part of a test map, and placed some layered terrain over it, but that layered terrain DID persist after saving & reloading the file. This issue seems to only happen in certain parts of the map.

I don’t know how to make heads or tails of this. I first noticed this happening after I did some tests with AGE and enabled some terrains that are normally hidden in the editor. But it’s also happening even after a reinstall of AoE2.

:arrow_forward: FREQUENCY OF ISSUE

:point_down: How often does the issue occur? CHOSE ONE; DELETE THE REST!

  • 100% of the time / matches I play (ALWAYS)

:arrow_forward: REPRODUCTION STEPS

:point_down: List CLEAR and DETAILED STEPS we can take to reproduce the issue ourselves… Be descriptive!

Here’s the steps to reproduce the issue:

  1. Place Snow, Foundation terrain as a base layer
  2. Enable Layering Mode and place a different terrain on top of the Snow, Foundation
  3. Save the file, close the editor, then re-open the editor and load the file.
  4. The layer terrain will be missing depending on where it is in the map.

:arrow_forward: EXPECTED RESULT

:point_down: What was SUPPOSED to happen if the bug you encountered were not present?
The layer terrain should persist after the file is closed.

:arrow_forward: IMAGE

:point_down: ALWAYS attach a PICTURE (.jpg, .png, .gif) or VIDEO (.mp4, YouTube link) that highlights the problem.

01 - Snow, Foundation terrain placed underneath several other terrain layers

02 - Save and close the file then reload it

03 - Layer terrains are missing after reloading file

:arrow_forward: GAME FILES (SAVE / RECORDING)

:point_down: Attach a SAVE GAME (.aoe2spgame) or GAME RECORDING (.aoe2record) of the match where you encountered the issue. Link it below if using an external file service.

This issue is now being tracked, thank you for the report.

1 Like

@aoescout Thank you! As I mentioned, I first noticed this a few days after using AGE to unlock the Corruption / Very Evil Fog terrain in the map editor, but I’m not sure if the problem was occurring before then as well or not since I don’t recall ever using the Snow, Foundation terrain before working on my terrain layering mod. The problem has persisted even after resetting everything in AGE to default and reinstalling AoE2:DE.