Some Chinese players can't use American civ in game although they bought it

And they all happened in these days. Is there anything wrong with the server?



I’m the manager of a Chinese fourm. I noticed three users had a situation in which American civilization could not be used in this weekend. One of them sent an email to the AOE official but it could not be resolved. Could you please help us? I’m asking them about steam and xboxlive accounts to help solving this problem.

@ vividlyplain
@ Ippert
@ gmenyhart

1 Like

Bua que raro, y por lo que veo les funcionan todos los demas DLC´s mmmm

of course this need DLC…sorry i don’t know what you mean.

Mod issue, it seems.

they don’t have mods however… but you remind me, I’ll ask them to delete the mod folder

@ vividlyplain
@ Ippert
@ gmenyhart
@ Breadalus

I just find another one who can’t use American normally. Could you please help us?

there was a similar issue a while back

1 Like

wow, thanks bro :star_struck:~~~~~~~~~~~

Update on this problem:

One user reports the problem is gone after disabling Steam’s “beta participation”. As in, participation in beta for the Steam client.

Thanks, we solved it :laughing:

Was it solved with disabling the beta participation or something else?

hey bro, the Steam was upgraded last night, and this way is Invalid now. They still cannot use American now.

it’s useless since the update of Steam

@LongBowWall sorry, we didn’t receive a ping because it seems you added a space between the @ and our usernames. Anyway, someone alerted me to this thread so I’m hear now. Unfortunately, I’m not sure about this stuff (I’m the map guy so not sure how to troubleshoot this one) but these players are likely best to reach out to Support: https://support.ageofempires.com/hc/en-us/requests/new and explain their problem.

Good luck!

2 Likes

ok, thanks bro~~~~~~~~

I think this is a universal issue, I can’t use the US anymore either. I wonder what changed that all of the sudden they’re just gone.

1 Like