Sorry, failed to connect multiplayer services. Pleas try again later

I just bougth the game and ı have been tring to play online but this eror don t let me for 5 hours. Is there anyone know why this is hapening? I wish your helpssss

I have bought the game from Steam today, and I have the same issue about multiplayer logging for the entire day. Is that a temporary problem about servers or is it a bug? Platform: Windows 10.

You cannot play in multiplayer if you opened the game and did not have your Steam account connected, you may also have run out of Internet. Close the game, check that you have internet, connect your Steam account and then open the game. If you have an account connected and cannot play in multiplayer, you probably haven’t signed up for “Xbox Live” yet.

I did everythings which you said but it still failed

I suggest contacting Support since we can just speak nothing more. We have no logs or any info about that situation.

Try open computer icon at right bottom desktop Windows. Click network. The network window open.
Now comback game, click multiplayer then click retry again.
It work for me. Hope u too. :slight_smile:

I couldn’t understand. After click network? We do nothing.

I have also created a post on Known Isuues, but I have not got any response so far. I have also purchased the game from the Xbox platform, I have still the same problem. I do not think that it is related with the Steam.

Did you refresh your multiplayer? I mean relog? Retry? Because it worked for me?

Of course, I did. Still the same after retrying.

Same problem here, I don’t know what to do…

I have the same problem. Whenever ı use my mobile cell , it can connect to multi services but the other times, I mean when I use wifi it doesn’t connect. I think itS because the connection. what can I do?


I am an IT specialist and I solved this problem on my friend’s computer. Steam or Age of Empires 2 DE uses ssl certificates to connect. If the appropriate certificate is not on the computer or there is a problem with the Certificate Manager, there may be problems with connecting to Online Services (Multiplayer).
However, I do not know what specific certificate is used by Steam / Age of Empires 2 DE. So the solution is to export the certificates to files on your computer where there is no connection problem. Then move them and import on the computer where the problem is. To enter the Certificate Manager use the WinKey + R hotkey and type certmgr.msc. Expand Trusted Root Certification Authorities and select Certificates folder. On the right side you will see the certificates that need to be exported on the computer where there is no problem with Multiplayer. Right click on certificate -> All tasks -> Export -> Next -> Next -> name the exported certificate (the name does not matter) and select path to save the file. Unfortunately, you have to do this with every certificate, because as I wrote, I don’t know what certificate Steam / Age of Empires 2 DE uses. You can use mine too if you want - I already did that for a friend. You can download them from here: After exporting the certificates, transfer them to the computer where the problem is and import them. Double-click the certificate file -> Install certificate -> Select Local Computer -> Place all certificates in the following store (second option) -> Browse -> Select Trusted Root Certification Authorities
For my friend it was enough to import the certificates from this folder to solve the problem. Perhaps other people will need to export / import certificates from the Intermediate Certification Authorities or Third-Party Root Certification Authorities folder - it all depends on what certificate is missing and what is the Certification Path for connecting to the Online (Multiplayer) service. Note: Even if you can see the imported certificate on your computer in certmgr.msc, where is the problem, you need to import it. The certificate may be revoked / corrupted.
The time should also be set correctly. It is best to synchronize the date and time with ntp servers. In Windows 10, right click on the clock -> Set date / time -> Set time automatically.

It is also recommended to reset Internet Explorer, Edge, Chromium browser settings to default settings. In Internet Explorer go to Internet Options -> Advanced -> check Delete personal settings -> Reset -> Restart computer. After reboot, go back to Internet Options in IE -> Contents -> click the Clear SSL state button

Other things that may affect the Multiplayer connection problem:
Windows Firewall or other AV / firewall installed.
In Windows 10, go to Settings -> Update and security -> Windows security -> click on Firewall and network protection -> Restore default firewall settings. After this, when you will run the application that connects to the Internet (eg Steam, Age of Empires 2 de) allow the firewall to connect. If you are an advanced computer user, you do not need to restore the default firewall settings. All you need to do is add rules in the firewall that allow Steam / Age of Empires 2 DE to connect to the Internet. The same should be done with the firewall of other companies.
You should also check the settings of your network card. Go to the Control Panel -> Network and Sharing Center -> Change network card settings -> right click on the adapter you are connecting to the Internet -> Properties -> click twice on Internet Protocol version 4 (TCP / IPv4) -> Select get IP address automatically / Select get DNS server automatically -> Click OK - if you are sure that your network gives IP addresses automatically! Otherwise, take a screenshot of the settings to return to them in the event of an Internet problem. Then, in the search field on the Start bar, type cmd -> right click on the black Command Prompt icon -> Run as administrator
Then execute the 3 commands:
ipconfig / flushdns
ipconfig / renew
ipconfig / registerdns

The connection may also be blocked by your ISP or router that you are using.

My friend had only a problem with the SSL certificate. I haven’t seen this solution described on the internet anywhere. I’ve seen solutions to install the game on partition D, reinstall Steam and the game, but that didn’t fix the problem. I also tried to use a VPN, but this solution also didn’t work.