Spies cannot be researched if the player has a Palisade Wall on the map

:arrow_forward: GAME INFORMATION

  • GAME BUILD #: 99404
  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED

When playing a .scx scenario and researching Spies for example for P1, and P1 has a Palisade Wall on the map, the view of opponents won’t be revealed at all. This applies only for .scx maps.

Update: I have looken inside the data. In normal AoC, there is a technology “Palisade Wall” with an ID of 117. It has an effect of ID 117, which does nothing. In the data of DE, the ID 117 tech is called “Disable Spies (Regicide only)”, and it also has the effect ID of 117, which effect disables Spies to research.

The problem may be based on technology 117 is researched because of the Palisade Wall on the map, even if the game mode is not Regicide.

:arrow_forward: FREQUENCY OF ISSUE

It happens 100% of the time when the player who gets Spies, had a Palisade Wall on the map at gamestart, even if it was already removed or converted.

:arrow_forward: REPRODUCTION STEPS

  1. Create a .scx scenario with normal AoC
  2. Add a Palisade wall for P1 and some units to keep alive (no need to add units for the enemies as they will get TCs by default)
  3. Add a trigger which researches Spies for P1
  4. Play the map with normal AoC, the research Spies will have effect, so you will see the enemy units
  5. Play the map with Definitive edition, the Spies won’t have any effect at all

:arrow_forward: EXPECTED RESULT

Spies should be researched properly even if the player who gets Spies researched has a Palisade Wall on the map.

:arrow_forward: GAME FILES (SAVE / RECORDING)

Here is an example .scx scenario which the bug can be tested with:

1 Like

I recreated the scenario in AOC and was not able to reproduce this problem in DE. I can’t download the file above, it’s already deleted.

I have updated the link.
To reproduce the problem, a new Single Player - Skirmish match has to be played instead of opening it with the editor and testing it there.
I hope, you will be able to reproduce the problem now.

Is THAT what’s causing it? I’ve been trying to figure out for the last week or so why spies isn’t an option in the castle lol

we are facing an issue where only chinese civ researching spies sometimes dont work not sure why.

Testing in Skirmish was the key. This issue is now tracked on our side, thank you for the report.