Steam invites never ever worked (greyed out)

:arrow_forward: GAME INFORMATION

  • GAME BUILD #: all builds up to date (2022/06/03)
  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED

My button for steam invites is greyed out in the game client.
AND if I right click on a friend in my Steam list, it doesn’t show ‘Invite to lobby’
I guess it’s a privacy option, but I am not sure.
I have this issue on multiple computers and also after reinstalling OS/game client.

:arrow_forward: FREQUENCY OF ISSUE

  • 100% of the time / matches I play (ALWAYS)

:arrow_forward: REPRODUCTION STEPS

Here’s the steps to reproduce the issue:

  1. Start game client.
  2. Try to invite people for a ranked team game.

It also doesn’t work, if already one player joined the lobby by the ingame invite function

:arrow_forward: EXPECTED RESULT

Steam Invites is not greyed out, in Steam it shows ‘Invite to lobby’ upon right click on a friend.

:arrow_forward: IMAGE

:arrow_forward: GAME FILES (SAVE / RECORDING)

  • none
1 Like

Hi @UnfamousScout !

Are you logged to Xbox Live?

Could you also try to verify your files in Steam? Aoe, Properties, Local Files


No, not logged in.

Files are verified.

Ok it’s volatile. I just was able to invite someone into a custom lobby i created. Steam invites in still greyed out, but on my steam friends list the ‘invite to lobby’ showed up in the context menu.

‘steam invites’ never works, is greyed out.
‘invite to lobby in friends list context menu’ is volatile, never working for ranked lobbies, sometimes working for custom lobbies.


Hey @UnfamousScout

Sorry that you are struggling with this issue. Unfortunately so far we cannot reproduce this.
I would recommend a full steam-reinstall, as well as a full game-reinstall.
If the problem is not solved, please contact support:

Good luck!

@ConvertThis4915 Yeah i did that already, it’s super weird.

@LukeSky8412 you have the same?

Yes, i have the same issue since a few months after installing the game. That was 2 years ago.
I reinstalled the game, etc, and it’s still greyed out. :frowning:

Do you remember changing some Steam setting or having restrictive privacy settings?

Nope, i don’t remember changing anything. It was a while ago though.

are you appearing online on steam? iirc with invis, its hit/miss sometimes it allows invite sometimes doesn’t.

I just got this issue for the first time, after it working for 2 years. My friend has had the same issue since DE came out though.

Is there one thing in this game which is not bugged? xD

1 Like

Do you have any kind of firewall or VPN installed?

Bro nobody is using a VPN, it just doesn’t work!
You have the source code, just fix it.

But pls fix the ridiculous crashes to desktop and take a look at the pathfinding before the India DLC release first.