Still no hitting particles of trebuchet with Chemistry researhed

Though it is not an important issue which affacts the gameplay, I really hope the FE devs can fix this issue. No hitting particles of trebuchet was an issue since several months of updates ago, the particles only exist without researching Chemistry. The only way to see the particle with Chemistry researched is to use CaptureAge to see a record game.

This is how hitting looks like without Chemistry:
You can see no flames inside because no Chemistry researched, that make sense.

This is the one with Chemistry (captured by CaptureAge), but it only appears with tool CaptureAge, you cannot see this particle in the game. There are flames within the explosion, but I have never seen this particle.


This issue is still exist since update 42695.0

Hope the devs can notice this, though it is not an important issue which affects the gameplay. I had reported this issue since several updates ago, initially on Steam community.

This is the one reported from another player:

The missing particle is shown on the second image(the town center), if this is still missing as such a graphical ‘feature’ in the game, it may be forgotten soon…

When are the devs gonna fix this bug?

No idea, dude. Hopefully as soon as possible.

1 Like

Bump to get the developers’ attention.

1 Like

Bump! Please fix it next update devs!


Please fix this problem devs. Been waiting forever

Hey guys, this is a known issue and is already tracked.
Have a nice day

In latest update, this issue is still not fixed.