Streaming limits the game itself (AoE2DE) to 60 fps

Hey guys,
whenever i start to stream AoE2DE over Discord my game limits itself to 60fps (shown in OSD, but feels like 20, absolutely unplayable), not more, not less, and i dont know why. It stays at 59-61 no matter what. With MSI Afterburner OSD my system is far away from its limits. When im not streaming its around 250-300. (I tried to stream with OBS on twitch once with the same effect.)
BUT it runs at 144fps (my monitor has 144hz btw) when i run the game in windowed mode and its running totally smooth and fine. but honestly no one can play this at windowed with the taskbar and stuff…
The problem only occures with aoe, with csgo i have 300+ fps and the stream looks fine with 60fps for the viewers.

it seems like the game recognises that my pc is streaming it and downscales itself to 60fps(feeling like 20).

things i already tried and dont change anything:

  • changing the fps rate (15, 30, 60) or resolution of the discord stream
  • changing the monitor resolution to full hd or other resolutions
  • changing the monitor refresh rate to 60, 100, 144hz
  • streaming the monitor or application has the same effect
  • turning on/off the second monitor
  • running the game in high performance mode

Allthough i think my system shouldnt be a problem:

  • ryzen 7 2700x, 8core, 4.2Ghz(OC)
  • radeon vega 56 8gb 1690mhz(OC)
  • 16gb 3200hz RAM
  • some M.2 SSD from samsung, idk exactly
  • Windows 10 64bit
    Monitor: 2560x1440 144hz

does anyone know what to do or if its possible to run the game at 144fps in fullscreen mode while streaming?