Stuttering in game single/multiplayer in high end desktop

:arrow_forward: GAME INFORMATION

:point_down: These details are CRITICAL; DO NOT skip them or your issue may not be reviewed.

  • GAME BUILD #: ######
    version 101.101.44834.0 6148570


  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED

Whatever in single or in multiplayers match the game become unplayable because random stuttering with 4 or more players. At the begining micro stuttering but with more population more ofter and long time, eve 20 seconds.

The specefications of my computer are:
AMD Ryzen 3900x
Nvidia GTX 970
2k Monitor
Game installed in a SSD

Other friends with similar specs have the same problem, always due a ryzen processor.

:arrow_forward: FREQUENCY OF ISSUE

:point_down: How often does the issue occur? CHOSE ONE; DELETE THE REST!

  • 100% of the time / matches I play (ALWAYS)

:arrow_forward: REPRODUCTION STEPS

:point_down: List CLEAR and DETAILED STEPS we can take to reproduce the issue ourselves… Be descriptive!

Here’s the steps to reproduce the issue:

  1. Install the game in a same specs ring with the same version.
  2. Play a game with hing popullation and 4 or more players IA or not.
  3. You will experience a stuttering.

:arrow_forward: EXPECTED RESULT

:point_down: What was SUPPOSED to happen if the bug you encountered were not present?

No stuttering with a high end desktop.

:arrow_forward: IMAGE

:point_down: ALWAYS attach a PICTURE (.jpg, .png, .gif) or VIDEO (.mp4, YouTube link) that highlights the problem.

:arrow_forward: GAME FILES (SAVE / RECORDING)

:point_down: Attach a SAVE GAME (.aoe2spgame) or GAME RECORDING (.aoe2record) of the match where you encountered the issue. Link it below if using an external file service.

1 Like

Same, I got this problem already since november.
When the hang occurs the GPU Clock is going down to nearly zero, CPU stay at 10 - 12 %.

BUT in the taskmanager i can see that the game ist switching the used CPU Cores some times, my Ryzen 5900x and your 3900x have 2 CCDs (6 cores per CCDs), is it possible that the stuttering occurs when it changes the used cores to the other CCD ? A friend with an AMD Ryzen 5600x (6 cores, only one CCD) dont face this problem at all.

I tried so many things but had no luck so far…

I read about some cases where the game switches to the integrated GPU or the anti-virus software blocked the game.
Some steps from the Support i had to test:

  • Check for Windows updates manually and install all of them
  • Re-install your GPU drivers, if you have recently updated them, try installing the previous version of drivers
  • Disable or uninstall your anti-virus software
  • Uninstall the game, restart your PC then re-install the game to your main drive
  • Make sure that the game uses your external GPU instead of your on-board graphic card
    (read the last part behind the following link)
  • Tips for Optimizing your Age of Empires Experience – Age of Empires Support

Hmmm okay that theory is a dead end…
I tried to test it with a fixed CPU core affinity for the AoE2DE_s.EXE but with no luck.