Sun Festival!

I think I have collected over 20 relics, aiming for the last quest in Sun Festival, collect 5 relics, not sure if im having a blond moment but its just not working for me.
Anyone having the same issue?

I just completed it while ago. I waited until relic timer is over.

More Details;
I played as Spanish
Map: Arabia
Age: Castle Age
Map: All Revealed
Resources: High
Lock Speed, Team Together

Same here. These quests are a bit buggy this year and some of them cannot be completed by VS AI game

Same here, I have tried various ways to do this including the suggestion, still nothing, most frutrating.

Hey, I set up a lobby, perhaps that will award the completion? you are welcome to join loby if your available, maybe you will get the credit also…

Game ID aoe2de://0/169951426

Try to put all the relics into a single monastery and delete your other monasteries.

Thanks Zetmus, Yes I have tried this, along with many variations, 18 hours on the same issue so far, I even attempted to try multiplayer, but that did not go well as player 2 opted for total domination of the map including castleing my town centre etc. one more attempt today will confirm that the game is seriously going down hill and unreliable. The shame is that AOE has been in my family and top of the playlist since 1988.

Single player, set player count to 1, at least I’m done

Hi @JK247G,
Could you share a replay of one of the matches where you collected 5 relics but didnt complete the challenge?
And the challenge specifically requires you to have 5 relics captured at once, I expect you already did that a few times though :smiley: