Sundjata mission 2 Granary CTD

Game Version:

  • Build (Verson 101.101.34223.0 4509956)
  • Platform Steam


The game Crashes when the AI begins attacking this Granary, don’t have the ability to protect it because it’s so far out and the base is actively trying to prevent me from being able to play the game by being so awkwardly made.

I was trying to fast Castle so that I could just put a castle in front of it, but the AI attacks me so fast that I either have to create units and delay it (Skirms/Scouts).

Reproduction Steps:

  1. As soon as the AI begins the process of attacking (not even finished with the attack animation yet)
  2. … Crash


Having to defend the base against so many archers early on makes it super hard that unless you get stone you can’t defend against the HUGE wave that Green sends. Oh you got an army of skirms to protect from the archers? here’s 30-40 Man At Arms that ignore all the buildings except the ones that cause the CTD.

Tried getting forward Stone but your ally always asks for too much help early on so I can’t secure it properly having to send skirms all the way up to his base.

Managed to get a Castle up, but there’s also a building in the allies base that also leads to a CTD, if the Ally wasn’t really bad and easily steamrolled it could be manageable but he’s soooo uselesss. I was 100% defended, but yellow was Gone because I only had enough stone for one Castle at a time.

All the resources you need are forward, 2 forward Boar, 2 Towers preventing you from walling early on.
Tried putting a Castle in Yellow’s base this time, you need the first one in your base + Murder holes. Got to send a few Melee units to Yellow’s base to prevent the TC from falling too.

I have the same problem.

Game Version:

Build (Verson 101.101.34223.0 4509956)
Platform Steam


I’m playing with Sundjata in mission 2 and when they come to attack my base the game is spoiled by going out to the desk, just after advancing to the age of castles.
I tried to save the game and continue from there but there’s no way.

Reproduction Steps:

  1. When the AI starts attacking my base (I happened to go up to the age of castles 1 minute earlier, but I don’t know if that’s my fault or not)
  2. Exit to the desk without giving any error message. If I save a departure just before and reload it, the same thing happens to me at the same point.

I have an i7 7700k, geforce rtx 2070 super, 32gb ram and SSD with a lot of free space.
I have tried everything they put in the forums, increase memory windows paging, install updated drivers, reinstall, remove the dlc with the ultra textures, by turning off anti-virus and other programs in the background, etc etc without getting to solve anything.

It is difficult to defend against archers and monks when they attack you at first, the first mission took me 7 hours.
Here after starting several times what I do is close my base with stone walls and put towers, that gives me time to kill the archers while I go up to the age of castles and increase resources to build future soldiers (archers).
I also sent three camps to chop stone at the base of the allies

Having the two towers helped, since they get attacked first and are easier to make pre Castle, as soon as the mission is stable it’s pretty easy.

When you’ve cleared out most of the enemies you can send the Convoy of Peace.

Not sure if it would work but if you build a gate in front of Teal’s base he shouldn’t be able to attack.

We just released an update that may resolve this. Check it out and let us know if there are still any issues. The full list of updates can be found here:

Age of Empires II: Definitive Edition — Update 34699