"Swift Site" steam achievement bugged?

“Begin capturing a Sacred Site immediately upon entering the Castle Age (III) as the Holy Roman Empire.”

Is it? I’ve done this a couple of times now. I have a prelate standing within the sacred site before building the castle age landmark. but still nothing

Make sure you are not using any mods or custom maps. Masteries and Achievements don’t count in this case.

Just tried again,it was just a standard skirmish against the intermediate ai, standard resources, start age 1, map concealed, no cheats/mods etc…Still nothing :frowning:

You’re not on a custom map, right? If so, try using something like Dry Arabia or Lipany? Also try completely restarting Steam as well (not just closing it, because it will remain running in the background if you do that). Sometimes I’ve had an issue where Steam does not register an achievement in other games and that fixed it.

Nope not on a custom map, I’m using dry arabia. tried again there after logging out and back in. still nothing

Finally got this to work thanks to another steam user
for anyone who runs into this problem you have to have the victory condition set to sacred site victory