Text string mods dont work

:arrow_forward: GAME INFORMATION

  • Build: latest on steam, 101.101.40220.0 5438859
  • Platform: Steam
  • Operating System: Windows 10
  • Gamertag:

:arrow_forward: ISSUE

text string mods dont work anymore

Changed a simple string :

in genie editor the string is ok
ingame the game still reads from default crap and refuses to read from my mod

:arrow_forward: REPRODUCTION STEPS

Here’s how to reproduce the issue:
1.Change a simple string :
123 or whatever
2.Load aoe:2de
3.Import local mod containing said modded string
4.use said mod for your game
5.Hover cursor over modded string ingame
6.Wonder wtf is going on and then get mad and dissapointed, because the game is broken and refuses to read from mod the modded string for some unknown reason

:arrow_forward: GAME FILES


:arrow_forward: IMAGE & ATTACHMENTS

:question: Attach a SCREENSHOT, VIDEO, DXDIAG .TXT FILE, or CRASH/GAME LOGS (if relevant).

mine still works. did you hit the “copy” button to all civ? default civ is gaia and you can’t play as gaia in game.

Issue solved
Yes it was because of the recent changes to modding
Yes my mods are all in C:\Users\xxxxx xxxxxxxxxxxxx\Games\Age of Empires 2 DE\41bbxzz8207645y76345y645\mods\local

i still am editing the key-value-modded-strings-utf8.txt directly in my mod, since the game launched, not through the genie editor because that causes the editor to crash.

‘write to language files’ in the supplied genie editor ( the one that comes with the steam version of aoe 2 DE ) is not working ( has it ever worked ? ), the editor instantly ctds if the option is ticked @ saving an mod that modifies an string or strings, anyway, been like this since at least aoe 2 DE released.