The game is broken on steam

On Linux and Mac systems. Now, I have a copy of Windows installed in my system, with AoE2 on it. However, I spend most of my time on Linux, because of various reasons. I can’t switch OS for playing for an hour, completely dumping wherever else I have going on at the moment.

I realize that this is not a priority for the devs, but it is an issue that affects quite a bit of people. It also seems unnecessary, as the game was running fine before the latest update.

People are doing what they can about it, but it would be much easier with the help of devs.

https://old.reddit.com/r/aoe2/comments/14kwzwa/cant_play_on_linux_latest_update_broke_game_steam/

I hope the devs can do something about this. Otherwise, this will be it for me and AoE2. Might have to move to 0ad or something. Or, HD on voobly. If this is not fixed soon and I find an alternative, I’ll post it here. But I hope it doesn’t get to that, because I love this game and want to play it as long as I can.

7 Likes

Same happened to me, after playing this game since the beginning on Linux (and a lot multiplayer games). I hope it could be a solution, because, I am not using windows anymore for my main machines and even when I love this game, I am not going to change my way to work during the day for one hour of playing. I know that AOE2DE is not listed as supported, but I hope something can be done to get Mac and Linux users to play it again.

1 Like

AoE2DE was running completely fine on Linux up until this patch. I played 500+ ranked matches in multiplayer on Linux, and it just stopped working. The question is not why we are trying to play DE on a non-Windows system, but why it suddenly stopped working.

5 Likes

Your brother doesn’t know what he is talking about. I’ve played over a 1000 hours on linux, and it’s been fine. Yes, it’s AoE2 DE, and yes, it’s on highest settings.

You don’t know this either. People have already cracked and ran AoE2 on linux. Within 10 hours of the patch. That has issues and how long it’ll work is questionable, still.

Another blatantly wrong statement, in context. As I said, I have been running AoE2 DE on ultra settings on linux for a long time now.

It feels like you have literally no idea about what this is. Why are you commenting with such authority, then? If you don’t know, just move on, or ask questions. Don’t pretend to know stuff.

3 Likes

Actually, I majorly misrepresented him. He never said anything about current versions on Linux, only that the CD version could run on Linux. I just assumed Linux wasn’t designed to handle it.

You’re right, I don’t know anything about the subject. I don’t know anything about any kind of technical subject to begin with. I guess I just felt superior because I was running the game on software it was designed for.

1 Like

So what is the idea of your comment? How are you contributing to help us with the issue?. We already know that the game is just officially Windows supported (I put the comment about it and we are not mandating for support, just asking if something can be done).

If someone like the author of the post or myself, has issues the idea is getting some help or at least an official response from the development team of the game(and you are not), so we can know if there could be some collaboration or we should just wait for the Proton people, and we also know that some of them are searching for solutions.

1 Like

I guess I was just having a bad day. I already deleted my comment, as it didn’t contribute to anything.

6 Likes

Hey, fair enough. We all have rough days and can get riled up sometimes. Have a good one, mate!

2 Likes

Not working for me either, I’m on Mac Mini and it worked fine previously.

Hope a fix can be found. In the meantime, HD and the nostalgia that comes with it it is.

2 Likes

In github, there is a fix. I just tested the fix and it works well. I have not played ranked, but it looks like regular multiplayer works well. It is very straighforward to apply the fix, but it takes time! Because it is recompiling Proton. Please, check the risks that is put in the original comment of the fix. (I just had to put SKIPINTRO in the launch params)

1 Like

Would you please be so kind and post the whole command?

1 Like

Hello! The steps are here:

You should install podman first (which is to run containers). In Ubuntu, I just had to run, sudo apt install podman.

It is a workaround, so probably could be better to work on the root solution.

1 Like

I run Age of Empires 2 DE on steam deck. Has worked in compatibility mode since December of last year, through all the other major updates.

Current update made it impossible to boot the game, documented for anyone on Linux/Mac OS with solutions found on GitHub but no way to play multiplayer.

I get that the devs are updating it, I get that it’s microsoft and windows based, but it’s a 20 year old game. People have been keeping this game alive for you to profit off it now, they’ve been running it on whatever machine they have or can afford.

Please Devs, let people play this game on other systems.

4 Likes

I was reading the thread and the first thing I guess was PROTON, are you using the dev or normal driver?

I was using Ubuntu almost since the first version, I was playing AOE2DE and 4 with almost no issues… but because now I’m training chess and Chessbase dont work in Linux I need to migrate to the darkside :smiley:

Try to report your issue diretly to proton test page for aoe2 and in the github.

Guys, just a quick update. Proton Experimental already has a fix for the game. You don’t need to follow the steps of the link I posted… Just go to Steam, search for Proton Experimental in the list of games and in “betas” option, setup the “bleeding edge” and that Proton version already contains the fix.

Do not forget to restart steam after that and ro set up the game with Proton Experimental.

2 Likes

Still not working for me. There is something called “Proton hotfix” which I’m trying to use, but the game doesnt start.

You need to use Proton Experimental, but you need to change the version/channel to “Bleeding Edge”. I have tested with my two machines and both work. Probably better steps:

  1. Open Steam
  2. Search in the game list (which also contains the tools), Proton Experimental. It is listed the same like a game.
  3. Go to properties
  4. Go to “Betas”
  5. Select the option: Bleeding-edge. Of course, download it.
  6. Restart steam. Proton Experimental will appear now like: “Proton Experimental [bleeding-edge]”
  7. Use that Proton Version for the game. That’s it.

You might need the multiplayer fix, but probably you already know that one

5 Likes

This works! Thanks, I really appreciate it.

The file wasn’t replaced, actually. In any case, I have a script for checking and replacing it 11

1 Like

I don’t know you, Tomate, but you are fantastic. I was pissed for not being able to play AoE2 anymore under Linux Steam, but it’s now a thing of the past I hope !

Note for those (like me) not reading the instructions above properly, you have to change the properties of Proton Experimental, not those of the game !

I tried all sorts of things like upgrading to the latest GE-proton, using barebones Proton, ancient GE-protons to no avail, so I’m very pleased to have this game sorted ! Many, many thanks Tomate !

1 Like

After I made these steps I get an error massage:
Unable to find a graphics accelerator with DirectX 11 support. Make sure your computer meets the minimum specifications.

Any tips to fix this?